.NetCore3.1发布在CentOS后连接SqlServer数据库异常(SslException)

原创
2020/06/05 16:50
阅读数 1.6K

本次部署,基于docker进行,拉取的mcr.microsoft.com/dotnet/core/aspnet:3.1镜像。 这里,我没有使用Dockerfile文件来创建镜像。

Interop+OpenSsl+SslException: SSL Handshake failed with OpenSSL error - SSL_ERROR_SSL

数据库连接成功,但是发生错误,具体如下图:

 

docker

发生这种错误,主要是由于,在数据库登录验证阶段使用了 SSL,导致身份验证不通过。允许的 ssl 最低版本和 SQL Server 数据库版不匹配。在这里,我采取基于上面拉取的镜像,启动容器进入容器内部,修改配置信息,具体代码如下:

sed -i 's/TLSv1.2/TLSv1.0/g' /etc/ssl/openssl.cnf

基于dockerfile的朋友,可以在Dockerfile配置文件中,增加如下代码,创建容器时来执行一个命令操作。

RUN sed -i 's/TLSv1.2/TLSv1.0/g' /etc/ssl/openssl.cnf

我把修改后的容器,从新制作了一个镜像,暂且命名为aspnetcoressl吧。docker images查看我们刚才创建的镜像。

[root@iZm5ec2cjkf2wt7aqpfw72Z ~]# docker images
REPOSITORY                             TAG                 IMAGE ID            CREATED             SIZE
aspnetcoressl                          3.1                 d619e179fc96        2 hours ago         207MB

aspnetcoressl是我们修改过配置文件后创建的镜像,也就意味着我们可要直接使用该镜像,来运行容器。

docker run --name tiku.api -v /data:/data -p 80:5000 -d d619e179fc96 dotnet /data/wwwroot/TiKu.Api/TiKu.Api.dll

最后,我把修改过的镜像,推送到docker.io我个人建的仓库里,如下图:

dockerhub

 执行下面代码,拉取修改后的镜像(aspnetcore3.1)。

docker pull lichaoqiang/netcore:3.1

最后,就可以基于整个镜像,部署.netcore3.1的程序了。

展开阅读全文
加载中

作者的其它热门文章

打赏
0
0 收藏
分享
打赏
1 评论
0 收藏
0
分享
返回顶部
顶部