jQuery Migrate 1.1 发布,jQuery 应用迁移辅助插件

原创
2014/03/25 15:04
阅读数 681

jQuery开发团队前一段时间发布了jQuery 1.9版本,删除了1.8版本中的部分API,为了使前端开发者能够顺利迁移至该版本,该团队还发布了迁移插件jQuery Migrate

当开发者需要在代码中使用新版本的jQuery时,可以在1.9或2.0版本中使用该插件来检测哪些功能已经弃用或移除,并可以在必要时恢复这些功能。更多信息见项目README

jQuery Migrate 1.1在之前版本的基础上,进行了一些改进,包括:

  • 支持console.trace()来跟踪警告信息,更易于诊断错误。

  • 对于无效JSON,会返回警告信息。

  • 提示“Logging is active”信息,以表明插件正在运行。

  • 出于安全因素,jQuery 1.9限制了字符串的处理,你可以通过新版Migrate插件来恢复该功能。但还是建议使用$.parseHTML()来处理HTML。

  • 对$("<button>", { type: "button" })会显示一个错误警告

最后,需要注意的是,你可以使用该插件将jQuery恢复到jQuery 1.6.4之后的任何一个版本的功能。

详细信息:http://blog.jquery.com/2013/01/31/jquery-migrate-1-1-0-released/

下载:


展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部