win8下nodejs安装express问题
win8下nodejs安装express问题
jianyu_21 发表于4年前
win8下nodejs安装express问题
  • 发表于 4年前
  • 阅读 527
  • 收藏 1
  • 点赞 0
  • 评论 0

移动开发云端新模式探索实践 >>>   

存一下,免得以后抓虾

虽然在Ubuntu下工作,生产环境也不会用windows。但是单位新配的本子上是win8,鸡肋啊,不能装双系统。可是做演示方便,所以还是装下nodejs和ADT之类的工具吧。

nodejs下,npm的时候报错,需要VS编译环境。下载了VS 2014 express版本,结果报错信息变了。

两种解决办法:

1 node-gyp configure --msvs_version=2014

npm install --msvs_version=2014

必须先安装VS才行。

  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 3
博文 9
码字总数 3957
×
jianyu_21
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: