开源中国

我们不支持 IE 10 及以下版本浏览器

It appears you’re using an unsupported browser

为了获得更好的浏览体验,我们强烈建议您使用较新版本的 Chrome、 Firefox、 Safari 等,或者升级到最新版本的IE浏览器。 如果您使用的是 IE 11 或以上版本,请关闭“兼容性视图”。
Java自由人 - 开源中国社区
技能积分 23719
活跃积分 970
粉丝 19549
加入于 2008/08/31 最近登录:昨天 23:36
红薯 2周前
在使用 printf 风格的字符串输出时,应该使用 %n 而不是 \n 因为前者是平台无关的! 
4 查看
红薯 4周前
昨天刚搞定 IDEA 下编辑器对 Java 10 的支持(详情) 可是点击编译或者直接运行 Maven 项目时又报错 但是在命令行下执行 mvn package 毫无问题! IDEA 的各种设置都指向 Java 10 。 疯了!...
7 查看
红薯 4周前
IntelliJ IDEA 2018.1 发布了,该版本增加对 Java 10 的支持。今天升级了一下做了个基本测试。 如果在 IDEA 上创建一个普通的 Java 项目,选择 Java 10 的 JDK 就可以实现对 Java 10 的支持 Module Settings 这里...
9 查看
红薯 4周前
maven-compiler-plugin 插件依赖于老的 ASM 版本,而这个 ASM 版本不支持 Java 10 。但是我们可以通过指定 ASM 版本来实现对 Java 10 项目的编译支持: <plugin> <groupId>org.apache.maven.plugins</groupI...
4 查看
红薯 1个月前
Mac 系统上,之前装的是 Java 8, 前些天 Java 10 推出,直接下载 dmg 文件升级后,现在 Eclipse 启动失败,找不到 Java 虚拟机了 该如何破呢?
16 查看
红薯 3个月前
今天发现在我的 Mac 上使用 J2Cache 时候,在连接 Redis 部分需要执行至少 5 秒以上。(J2Cache 默认使用的是 JedisPool 连接 Redis),然后我写了一个简单的代码用 Jedis 类直接连是很快的,说明 Redis 服务本身...
5 查看
红薯 3个月前
Jedis 的 JedisCluster 模式下没有提供 keys(...) 方法,一般该如何破呢? 为什么会不提供这个方法吗?难道在集群环境下有难度? 
3 查看
红薯 4个月前
Maven <dependency> <groupId>jline</groupId> <artifactId>jline</artifactId> <version>2.14.2</version> </dependency> 使用方法: ConsoleReader reader = new ConsoleReader(); line = reader....
0 查看
红薯 4个月前
想自行编译 Semantic UI ,安装官方的指引来操作: npm install semantic-ui --save cd semantic/ gulp build 只生成了 semantic.js 和 semantic.min.js ,但没有生成 semantic.css 和 semantic.min.css gulp bu...
4 查看
红薯 4个月前
如题,ElasticSearch 和 Solr 这两个搜索服务器哪个更靠谱,更适合大规模的数据搜索?
18 查看
顶部
×
动弹一下 还可以输入5
单图/多图
网络图片
上传图片
9 张,还能上传 9
  • +
发布
×
设置备注名:
保存
用户尚未登录,点击这里登录