文档章节

python 创建虚拟环境机

猿神出窍
 猿神出窍
发布于 2017/02/24 16:52
字数 86
阅读 9
收藏 0

 前提: 在Linux环境下 

 1 下载并安装包管理器pip:

wget -o get-pip.py https://bootstrap.pypa.io/get-pip.py&&python get-pip.py

2 安装virtualenv

 pip install virtualenv

3  创建

virtualenv envtest --no-site-packages

4 进入虚拟环境

 cd envtest/ 

5 激活

. bin/activate

特别说明激活不能少了点(.)

退出命令: deactivate

删除虚拟环境
    rm -r envtest

 

© 著作权归作者所有

共有 人打赏支持
猿神出窍
粉丝 16
博文 173
码字总数 61165
作品 0
沙坪坝
项目经理
在Win10和Linux上分别安装Python虚拟环境

很多初学者会使用windows作为开发机使用, 今天就来看下如何在win10和Linux下分别安装Python虚机环境。虚机环境有非常多的优点,今天我们用的虚拟环境是virtualenv。 virtualenv用于创建独立...

p柯西
06/02
0
0
python虚拟环境virtualenv下安装MySQL-python

我们在Windows下开发python应用时,可能需要安装各种第三方模块,但如果又不想污染公共的python环境,怎么办呢?最好是在各自的 python工程中创建一个virtualenv虚拟环境。博主最近需要在虚拟...

ipcpu
06/28
0
0
Pipenv一键搭建python虚拟环境

由于python2和python3在部分语法上不兼容, 导致有人打趣道:"Python2和Python3是两门语言" 对于初学者而言, 如果同时安装了python2和python3, 那运行python程序就可能会遇到2和3混用的尴尬 为...

木子昭
05/20
0
0
Centos7下安装python3并安装虚拟环境

引言 服务器自带的python版本大多是2.X,而且有些系统应用依赖于默认的python环境。但有时候要用到python3,为了不与系统的python环境相冲突,就新安装python3版本并使用虚拟环境。 安装准备...

_缘君_
05/02
0
0
为什么你的python版本一团糟?因为少了这个操作

坑人的版本 Python 的版本问题一直是个广被吐槽的黑点。以至于有人调侃说: Python 是世界上最好的两种语言! 在这里我要说明下,对于初学者来说,版本间的语法差异其实并不大。现在刚开始学...

crossin
前天
0
0

没有更多内容

加载失败,请刷新页面

加载更多

TypeScript基础入门之高级类型的多态的 this类型

转发 TypeScript基础入门之高级类型的多态的 this类型 高级类型 多态的this类型 多态的this类型表示的是某个包含类或接口的子类型。 这被称做F-bounded多态性。 它能很容易的表现连贯接口间的...

durban
11分钟前
0
0
tomcat中的几种log catalina localhost

体会 catalina.out catalina.log 是tomcat的标准输出(stdout)和标准出错(stderr) cataliana.{yyyy-MM-dd}.log和localhost.{yyyy-MM-dd}.log 是通过logging.properties配置的tomcat自己运行的......

onedotdot
33分钟前
1
0
Oracle return exit continue

常在循环体中看到下面3种语句: return exit continue 举例说明 啥都没有 -- none begin for i in 1 .. 10 loop if i < 5 then dbms_output.put_line('i < 5, i = ' || to_char......

taadis
今天
3
0
JSONObject 转换时出错 InvocationTargetException

JSONObject 转换时出错java.lang.reflect.InvocationTargetException 一时看不出来是什么问题。 挺奇怪的。 百度参考了一下这个 网页的解决方案 说是类型不对,空? 仔细查看代码,果然是有一...

之渊
今天
3
0
no such module 'pop'问题

在github上 clone 了一个 swift 项目,编译时提示"no such module 'POP'"错误,查了一下居然是因为podfile中指定的最低版本是iOS 11.0,大于我测试手机的iOS版本10.3.3,将Podfile中的最低版...

yoyoso
今天
3
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部