org.apache.thrift.TApplicationException: Required field 'client_protocol' is unset!

原创
2016/09/20 22:43
阅读数 889

##问题描述

使用 Hive JDBC 连接 Hive Metastore 报以下错误:

hive-error

##原因分析

Hive JDBC 版本和 Hive 版本不一致导致的,集群中使用的 Hive 版本是 0.12.0-cdh5.0.2, 但是 Hive JDBC 的版本却是 0.13.1-cdh5.3.1。

##解决方案

将 POM 文件中 Hive JDBC 依赖版本改成 0.12.0-cdh5.0.2。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部