python.exe: No module named pip.__main__; 'pip' is a package and cannot be directly executed

原创
2020/09/01 17:55
阅读数 9.3K

WARNING: You are using pip version 19.2.3, however version 20.2.2 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

今天在命令行安装mysql 的连接驱动,发现警告pip版本太低。

执行了:python -m pip install --upgrade pip  结果报错:

python.exe: No module named pip.__main__; 'pip' is a package and cannot be directly executed

解决办法:python -m ensurepip

再次执行:python -m pip install --upgrade pip

升级成功

展开阅读全文
加载中

作者的其它热门文章

打赏
1
0 收藏
分享
打赏
0 评论
0 收藏
1
分享
返回顶部
顶部