解决cuda10.0 gcc versions later than 7 are not supported的方法

原创
2020/04/01 09:58
阅读数 3.7K

操作方法:

sudo apt-get install gcc-7 g++-7
sudo mkdir /usr/local/gcc7
cd /usr/local/gcc7
ln -sf /usr/bin/gcc-7 cc
ln -sf /usr/bin/gcc-7 gcc
ln -sf /usr/bin/g++-7 g++
ln -sf /usr/bin/cpp-7 cpp
ln -sf /usr/lib/gcc/x86_64-linux-gnu/7/cc1 .
ln -sf /usr/lib/gcc/x86_64-linux-gnu/7/cc1plus .
export PATH=/usr/local/gcc7:$PATH

这样nvcc,查找gcc时就会先找gcc7,问题就解决了。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部