文档章节

Git 编译安装

jepacd
 jepacd
发布于 2016/09/20 14:14
字数 232
阅读 59
收藏 0

【推荐】2019 Java 开发者跳槽指南.pdf(吐血整理) >>>

1 - make configure

you can use autoconf generated ./configure script to set up install paths (via config.mak.autogen)

执行make configure生成.configure脚本时,报如下错误:

/bin/sh: autoreconf: command not found (centos 6.5 install qemu from source code)

需要安装autoconf

yum install install autoconf automake libtool

2 - configure

./configure --prefix=/usr/local/git-2.10.0

3 - make

在make的过程中可能会报很多错误

3.1 - make[1]: *** [perl.mak] Error 2

Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Makefile.PL line 3.
make[1]: *** [perl.mak] Error 2
make: *** [perl/perl.mak] Error 2 

解决方法:

yum install perl-ExtUtils-MakeMaker package

3.2 - make[1]: *** [po/bg.msg] 错误 127

tclsh failed; using unoptimized loading
    MSGFMT    po/bg.msg make[1]: *** [po/bg.msg] 错误 127

解决方法:

yum install tcl  build-essential tk gettext

3.3 - Unable to find remote helper for 'https'

yum install -y curl curl-devel

重新安装git

4 - doc

$ make all doc
$ make install install-doc install-html

需要安装asciidocxmlto

$ yum install asciidoc
$ yum install xmlto

5 - 建立软连接

$ ln -s -f /usr/local/git-2.10.0 /usr/bin/git

© 著作权归作者所有

下一篇: awk
jepacd
粉丝 5
博文 153
码字总数 210363
作品 0
朝阳
程序员
私信 提问
CentOS 6 编译安装Git-2.9.5

CentOS 6自带的git版本是1.7 安装编译环境 安装gcc # yum install gcc gcc-c++ autoconf make automake -y 安装编译所需的包 # yum install curl-devel expat-devel gettext-devel openssl-d......

898009427
2018/01/11
0
0
三、安装Git

它是最容易使用您的Linux发行版的软件包管理器的Linux安装Git的首选 Debian/Ubuntu Fedora (up to Fedora 21) (Fedora 22 and later) Gentoo Arch Linux openSUSE FreeBSD Solaris 11 Expre......

树上的风筝
2016/05/02
38
0
centos7 安装 git

1.安装编译git时需要的包 yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel yum install gcc perl-ExtUtils-MakeMaker 2.下载git源码 cd /usr/src wget https:/......

Atom_me
2016/11/12
100
0
Centos 6.5编译安装git 2.9.3

记录一下: 开发需求,需要安装新版git,Centos6.5 yum安装最新的是1.7.1,只能通过编译安装 步骤: 1、下载新版的git 地址:https://github.com/git/git/releases,选择 git-2.9.3.tar.gz,...

hironepiece
2016/08/29
0
0
Git 的安装和连接gitlab的一些坑

Git的安装 安装需要的依赖 #yum remove git #yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel #yum install gcc perl-ExtUtils-MakeMaker 下载新版本的git htt......

xitaotao
2017/03/10
0
0

没有更多内容

加载失败,请刷新页面

加载更多

OSChina 周四乱弹 —— 浙江台的电话号码倒是记得挺牢

Osc乱弹歌单(2019)请戳(这里) 【今日歌曲】 @巴拉迪维 :《Out On The Streets》 一直不理解北欧人对重金属和死亡摇滚的热情,听完这首歌好像理解了。#今日歌曲推荐# 《Out On The Stre...

小小编辑
今天
5
0
Leetcode PHP题解--D121 21. Merge Two Sorted Lists

D121 21. Merge Two Sorted Lists 题目链接 21. Merge Two Sorted Lists 题目分析 合并两个有序链表。 思路 逐个遍历两个链表,把小的数字塞入数组里。之后再拼起来。 最终代码 <?php/** *...

skys215
今天
5
0
mars-config 动态配置管理

mars-config 码云地址:https://gitee.com/fashionbrot/mars-config 介绍 spring mvc 、springboot 动态配置系统。http 轮训方式 更新 动态配置 软件架构 软件架构说明 后端使用技术 :sprin...

fashionbrot
今天
14
0
女朋友玩吃鸡手游被开挂老哥骗炮,我见义勇为将骗子绳之以法

大家好,我是乔哥。 晚上10点以后下班后我回到自如出租房里面,开始处理公众号粉丝发来的消息,一条一条处理,突然看到了这么几条消息,吸引了我的眼球: 然后我就和这位女粉丝小红(化名)聊...

gzc426
今天
9
0
两款软件

fadetop保护眼睛软件 Snipaste截图软件

伟大源于勇敢的开始
今天
7
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部