CentOS 7 升级node.js提示Requires:http-parser >= 2.7.0错误
博客专区 > Swire 的博客 > 博客详情
CentOS 7 升级node.js提示Requires:http-parser >= 2.7.0错误
Swire 发表于8个月前
CentOS 7 升级node.js提示Requires:http-parser >= 2.7.0错误
  • 发表于 8个月前
  • 阅读 70
  • 收藏 0
  • 点赞 0
  • 评论 0

移动开发云端新模式探索实践 >>>   

摘要: Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel) Requires: libhttp_parser.so.2()(64bit) Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel) Requires: http-parser >= 2.7.0

之前在去年安装node.js时,yum install直接就搞定。这次虚拟机太久未登陆,于是登陆'yum update'遇到了如下错误:

Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: libhttp_parser.so.2()(64bit)
Error: Package: 1:nodejs-6.11.1-1.el7.x86_64 (epel)
           Requires: http-parser >= 2.7.0

查了下,是因为CentOS 的EPEL里已经移除了Node.js而放在了REHL中。 因此需要去下载http-parser安装即可.

rpm -ivh https://kojipkgs.fedoraproject.org/packages/http-parser/2.7.1/3.el7/x86_64/http-parser-2.7.1-3.el7.x86_64.rpm
标签: Node.js CentOS
  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 1
博文 57
码字总数 10453
×
Swire
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: