发点牢骚

原创
2017/08/19 15:24
阅读数 16

前天把系统删崩溃了,我只是想清理一下多余的软件包,然后就悲剧了。

当时的系统是Debian testing ,由于是从Debian 9 升级过去的,有一些包有点残留。系统里既装了Python3.5又装了Python3.6 理所当然的要卸掉一个。于是乎我就:sudo apt-get purge python3.5 这下好了,竟然卸了一大堆的包,什么gnome x11 fcitx 全给我卸了。我记得高中的时候:sudo apt-get purge emace-en 没看输出,直接重启,然后开不了机了。这次我看了输出,我心惊胆跳的一个个手动装上。顺利重启,但是输入法出了问题,死活配置不好。后来发现,有一个服务给卸了,我没有装上。但我不知道那个服务叫啥啊。

算了,也该备份一下系统了,顺便重新安装换成UEFI启动。为了安装后系统没有太多累赘,直接使用Debian testing的网络安装iso。但这个iso有个BUG,启动后,鼠标键盘没反应.Debian 9.1的iso倒是没问题,但这样再升级到testing又是一堆累赘。

Ubuntu!第一次使用linux是在高一下学期,当时用的就是Ubuntu。因为神舟本的坑爹做工,用了Debian两年,现在我又要回归Ubuntu了! UEFI下启动iso,手动分区,第一个分区是efi分区就完了,傻瓜式安装。

“内部错误”我在用Gvim的时候遇到了,反正Gvim不好用,换成vscode。atom太慢了,那个圈圈要转好久。至于vim吗,毕竟配置折腾了那么久,用来改配置文件好了。vscode的markdown预览真的很好用,默认的就可以啦,不用配置一堆乱七八糟的,再装个markdownlint插件(这个vscode有推荐的)就完美啦。还有内嵌终端,太棒啦,以前总想着给vim配置出一个内嵌终端的东西来,tmux之类的,现在直接拿来就用,简单配置一下就好啦。

 

--------------------------------2017-10-18----------------------------------

又换回Debian了,Debian对UEFI支持虽不如ubuntu,但还是可以安装的。vscode实在太好用了

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部