如何在64位版本Linux上开发运行32位应用程序

2015/08/27 11:11
阅读数 636

最近换了Linux系统,由i686换成了x86-64,导致在进行开发的时候出用不了原来SDK中32位的开发工具。于是,博主找到如下文章,博主亲测实用:

如何在64位版本Linux上开发运行32位应用程序

内容如下:


很多程序员(特别是别的公司的)跟我抱怨说他们32位软件无法在我们的64位Linux系统上正常运行,而在他们32位机上正常,其实这个很好解决,一般 是64位系统安装后没有默认安装glibc的32位版本,通过简单的执行以下命令即可实现在64位Linux系统上开发运行32位应用程序,而不用重新安 装操作系统。

yum install glibc*.i686 -y

如果还提示少某个so文件,安装对应的库,如提示缺少libz.so,则安装libzip以及libzip-devel的64位和32位版本,如果提示缺少libssl.so则安装openssl以及openssl-devel的64位和32位版本,命令行如下:

yum install libzip libzip-devel -y
yum install libzip.i686 libzip-devel.i686 -y
yum install openssl openssl-devel -y
yum install openssl.i686 openssl-devel.i686 -y

如果出现:i386 architecture of input file xxx.o is incompatible with i386:x86-64

则很有可能是原来编译的 *.o 文件没有清除掉。将其清除后再编即可~

展开阅读全文
打赏
0
6 收藏
分享
加载中
更多评论
打赏
0 评论
6 收藏
0
分享
返回顶部
顶部