debian5 安装node.js

原创
2013/10/14 11:53
阅读数 257

node.js安装环境需要python的版本是2.6或者2.7以后的,而在debian5上默认的python版本是2.5的,所以第一步得先升级python版本,然后才能安装node.js。

1 安装编译环境

apt-get install build-essential

2 源码安装python2.7.2

  下载python源码

wget 'http://www.python.org/ftp/python/2.7.2/Python-2.7.2.tgz'
  安装

tar zxvf Python-2.7.2.tgz
cd Python-2.7.2/
make
make install

3 源码安装node.js v0.10.20

  下载node.js源码

wget 'http://nodejs.org/dist/v0.10.20/node-v0.10.20.tar.gz'
  安装

tar zxvf node-v0.10.20.tar.gz
cd node-v0.10.20/
./configure
make

  make的时候报错ImportError: No module named bz2

   这才知道node.js还需要bz2模块,python实验了一下,确实没有bz2模块,得嘞,得重新编译python了,看来一帆风顺是不可能的。

4 重新安装python+bz2模块

  进入python源码目录编译zlib模块

cd Python-2.7.2/Modules/zlib
./configure
make
make install
  然后重新安装python

cd Python-2.7.2
python setup.py install
  安装完后发现一个问题,还是失败的


  google一番,解决方法如下,还得重新编译zlib模块,不过得修改一下源码

cd Python-2.7.2/Modules/
vim Setup
#去掉下面一行前面的注释#
zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
cd zlib
./configure
make
make install
#重新安装python
cd Python-2.7.2/
python2.7 setup.py install
  现在看看结果,zlib模块的错误已经没了


  但是向前翻了几行,白高兴了一场,搞了半天bz2模块还是没发现


  这个应该是系统中相关的bz2 lib库没有安装,所以:

apt-get install libbz2-1.0 libbz2-dev bzip2
  然后再重新操作一遍上面的步骤


  这时候看到bz2模块已经不在提示里面了。


5 重新安装node.js,步骤和第三部一样,最终结果如下




展开阅读全文
打赏
0
1 收藏
分享
加载中
更多评论
打赏
0 评论
1 收藏
0
分享
返回顶部
顶部