文档章节

Windows(64位IIS)未在本地计算机上注册“Microsoft.Jet.OLEDB.4.0”提供程序

NathanJoy
 NathanJoy
发布于 2016/04/22 18:45
字数 216
阅读 39
收藏 0

在Windows 7(32位)用.Net开发的Excel导入数据表功能,测试后一切正常,站点发布挪到Windows Server 2008(64位)上就意外了,出现错误提示,运行程序,抛出异常:未在本地计算机上注册 Microsoft.Jet.OLEDB.4.0 提供程序,搞了老半天,不知道什么原因,后来搜过了一下,才发现解决问题的办法是如此简单:

解决方法之一:

编译项目指定目标平台为x86就完了,不能用any cpu

生成->配置管理器->平台->点击Any Cpu选项卡->新建->新建平台->X86

解决方法之二:

在对应的 IIS 应用程序池中,“设置应用程序池默认属性”/“常规”/”启用32位应用程序”,设置为 true。

本文转载自:http://www.cnblogs.com/freegodly/p/4207757.html

NathanJoy

NathanJoy

粉丝 1
博文 21
码字总数 5090
作品 0
西安
程序员
私信 提问
Accusoft结构化工具包FormSuite for Structured Forms常见问题解答(二)

FormSuite for Structured Forms是结构化的表单处理SDK和字符识别工具套包,包括表单处理工具FormFix和字符识别工具SmartZone。所有表格处理控件被设计为可以通过内存到内存的数据传输模式进...

ymy_666666
2018/12/21
6
0
ASP无法启用Microsoft.Jet.OLEDB.4.0

Microsoft.Jet.OLEDB.4.0是系统自带的,window 32位系统都带有各种数据库的驱动,安装IIS后只要能运行ASP这个Jet就能用。不过在64位版中情况不一样,Jet没有64位版 的,需要设置下。 在 IIS ...

zhangsirsdo
2014/07/21
956
0
Window2003 64位IIS报错“Microsoft.Jet.OLEDB.4.0

Window2003 64位IIS报错“Microsoft.Jet.OLEDB.4.0” 由于64位操作系统不支持Microsoft OLE DB Provider for Jet驱动程序,也不支持更早的Microsoft Access Driver (*.mdb)方式连接。所以用于...

长平狐
2013/04/25
101
0
Acess Engine - SQL Assistant下载备忘

使用 OleDb 访问Acess时需要在连接字符串中指定使用的数据引擎的版本 出现问题 解决办法 安装Office套装或者独立的 Acess Engine 下载地址 Microsoft Access 2010 数据库引擎可再发行程序包 ...

夏至如沫
03/22
5
0
“12306余票查询“在64位win8上,jet.oledb.4.0”问题

@eatapple 你好,想跟你请教个问题:“12306余票查询“在64位win8上,总遇到未在本地计算机上注册“jet.oledb.4.0”提供程序这个问题,改为release总是有命名空间缺失。 如: 错误 4 未能找到...

liguobao
2013/11/18
536
2

没有更多内容

加载失败,请刷新页面

加载更多

CSS3

一.复杂选择器 1.兄弟选择器 具备相同父级元素的平级元素之间称为兄弟元素 注意:兄弟选择器,只能往后,不能往前找 (1).相邻兄弟选择器,获取紧紧挨着某元素后面的兄弟元素 选择器1+选择器2...

wytao1995
17分钟前
3
0
Jmeter录制

1. 加HTTP(s) Test Script Recorder 2. 在 recorder下面加reocrding controller 3. 在HTTP(s) Test Script Recorder中设置下面几项 4. browser设置proxy, 注意端口要和step3中jmeter中的一致......

Rebecca_Hu
22分钟前
3
0
DIV+CSS忽悠前端小白

在大约两年前,DIV+CSS是一对很诱人的组合,会用DIV+CSS制作网页的人,常常会被人赞以大拇指的,记得06年初的时候,我用 div+css布局的一个纯静态网站还拿了学校网页设计比赛的一个奖。 今天...

前端老手
25分钟前
3
0
Win10子系统 linux(Ubuntu18.04) 安装Docker

1)原文件备份 sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak 2)编辑源列表文件 sudo vim /etc/apt/sources.list 3)将原来的列表删除,添加如下内容(中科大镜像源) deb http...

jxldjsn
27分钟前
3
0
Ubuntu16.04安装Qt5.12.2

Ubuntu16.04安装Qt5.12.2 第一步:下载文件 https://download.qt.io/official_releases/qt/5.12/5.12.2/ 第二步:安装依赖库 sudo apt-get install build-essential sudo apt-get install li......

shzwork
33分钟前
5
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部