文档章节

RouterOS多根光纤接入进行叠加

fir01
 fir01
发布于 2017/04/19 11:14
字数 869
阅读 591
收藏 0

「深度学习福利」大神带你进阶工程师,立即查看>>>

前言:不知道是不是做网管的人都比较扣,基本没完整的文档。摸索了一天,基本以前学校学的东西又复习了一下

 

 

#一、注意:请先将routeros预置的配置文件删除或者重置。
#原理:将进入路由和局域网的数据都打上标记mangle,不同的光纤宽带入口数据打上不同的mangle进行分类,那么就能保证发出去的包又能从同一个宽带出口进入,
#举例:我有一个100兆的zip文件,发出去的数据被routeros路由通过两个光纤出口发,在routeros里面会被打上不同标签,那么就变成
#多宽带输出;接受数据的时候一样,网上的数据都会经过routeros,他匹配标志,然后又定位我的ip,将数据发给我.
#二、设置域名服务器和局域网的DHCP池
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 primary-dns=222.246.129.80 secondary-dns=59.51.78.210
/ip address add address=192.168.87.1/255.255.255.0 interface=LAN comment=LAN
#三、修改最小分包的大小
/ip firewall mangle add chain=forward comment="change MSS" protocol=tcp tcp-flags=syn action=change-mss new-mss=1440
#四、添加PPOE账号
/interface pppoe-client add name=pppoe-out1 interface=ether2 user=073198887556 password=357770 add-default-route=no disabled=no
/interface pppoe-client add name=pppoe-out2 interface=ether3 user=073198529234 password=167256 add-default-route=no disabled=no
#五、mangle标记PPOE端口进出的数据包。类似我们对数据包进行打个标记,以便分类进行控制
#使用mangle标记连接和路由的数据包,标注第一条PPOE网线的:
/ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=pppoe-out1 new-connection-mark=adsl_conn_1 passthrough=yes
/ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=adsl_conn_1 disabled=no new-routing-mark=adsl_rout_1 passthrough=yes
#使用mangle标记连接和路由的数据包,标注第二个PPOE条网线的:
/ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=pppoe-out2 new-connection-mark=adsl_conn_2 passthrough=yes
/ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=adsl_conn_2 disabled=no new-routing-mark=adsl_rout_2 passthrough=yes
#六、标记局域网进出的数据包,注意一下局域网的mangle标记的路由名称必须和PPOE的mangle对应上
#标记局域网LAN的接入第一条PPOE(pppoe-out1)的路由和连接,注意一下这里的路由标记必须和“pppoe-out1路由标记”相同:adsl_rout_1
/ip firewall mangle add action=mark-connection chain=prerouting comment=PCC_1 disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_conn_1 passthrough=yes per-connection-classifier=src-address-and-port:2/0
/ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=adsl_conn_1 disabled=no in-interface=LAN new-routing-mark=adsl_rout_1 passthrough=yes

/ip firewall mangle add action=mark-connection chain=prerouting comment=PCC_2 disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_conn_2 passthrough=yes per-connection-classifier=src-address-and-port:2/1
/ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=adsl_conn_2 disabled=no in-interface=LAN new-routing-mark=adsl_rout_2 passthrough=yes
#七、将PPOE标记的包和局域网标记的包通过路由连接上.
#将标记的“pppoe-out1连接和路由”和“LAN局域网接入pppoe-out1被标记的连接和路由”都配置到pppoe-out1端口
/ip route add check-gateway=ping comment=ADSL_1 disabled=no distance=1  dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=adsl_rout_1
/ip route add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1
#将标记的“pppoe-out2连接和路由”和“LAN局域网接入pppoe-out2被标记的连接和路由”都配置到pppoe-out2端口
/ip route add check-gateway=ping comment=ADSL_2 disabled=no distance=1  dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=adsl_rout_2
/ip route add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out2

#配置局域网的网络地址转换,屏蔽外网知道内网的IP
/ip firewall nat add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out1
/ip firewall nat add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out2

 

fir01
粉丝 19
博文 110
码字总数 34117
作品 0
长沙
项目经理
私信 提问
加载中
请先登录后再评论。
浅入浅出Android(003):使用TextView类构造文本控件

基础: TextView是无法供编辑的。 当我们新建一个项目MyTextView时候,默认的布局(/res/layout/activity_main.xml)中已经有了一个TextView: <TextView 运行效果如下: 修改其文本内容...

樂天
2014/03/22
685
1
数据中心生命周期管理--Foreman

Foreman是一个集成的数据中心生命周期管理工具,提供了服务开通,配置管理以及报告 功能,和Puppet Dahboard一样,Foreman也是一个Ruby on Rails程序.Foreman和 Dashboard不同的地方是在于,Fore...

匿名
2012/10/24
1.5W
0
商铺记账系统软件--bluebee蓝蜜蜂记账系统

此项目已废弃:) Donate捐助 bluebee accounting system is a popular and free accounting system for individual businesses.This system focus on the individual businesses operation......

刘学炜
2013/04/18
1.4W
10
Arduino 兼容开发板--Microduino

Microduino 是 Arduino 的兼容开发板。 Microduino 采用 U 型 27pin Microduino 接口规范,尺寸小巧,长25.4mm X 宽27.94mm,仅一枚1元人民币硬币的大小。轻量化的设计让Microduino在对尺寸、...

匿名
2013/05/14
8.1K
0
卷积神经网络初探

前言 目前为止我已经完整地学完了三个机器学习教程:包括“Stanford CS229”,"Machine Learning on Coursrea" 和 "Stanford UFLDL",卷积神经网络是其中最抽象的概念。 维基百科对卷积的数学...

Lee的白板报
2015/12/24
8.4K
14

没有更多内容

加载失败,请刷新页面

加载更多

MySQL索引相关

一、索引分类 1、单列索引 1.1、主键索引(不能包含空值) 1.2、唯一索引(可以包含kong'zhi) 1.3、普通索引 2、多列索引 2.1、组合索引 3、全文索引 3.1、全文索引只针对大文本字段有效,比如:...

城里的月光
37分钟前
21
0
二级分销的理解

人人商城分销定义 例如: 分销商:A、B、C、D、E 群体1:A是B的上级分销商,B是C的上级分销商,C是D的上级分销商,则他们分销层级是:A是一级分销商,B是二级分销商,C是三级分销商 群体2:B...

红翼网
40分钟前
6
0
HBase/TiDB都在用的数据结构:LSM Tree,不得了解一下?

LSM Tree(Log-structured merge-tree)广泛应用在HBase,TiDB等诸多数据库和存储引擎上,我们先来看一下它的一些应用: 这么牛X的名单,你不想了解下LSM Tree吗?装X之前,我们先来了解一些...

Monica2333
40分钟前
16
0
Linux下如何高效切换目录?

Linux 下对于目录的切换,大家肯定会想到一个命令:cd 命令。这个是 Linux 下再基本不过的命令,如果这个命令都不知道的话,赶紧剖腹自尽去吧。 cd 命令确实很方便,但如果需要频繁在下面的目...

良许Linux
43分钟前
27
0
限流算法

1 计数算法 2 滑动窗口 (可以解决计数算法 临界线 QPS超过限流问题) 3 漏桶算法 4 令牌桶算法

yzzzzzzzz
47分钟前
3
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部