文档章节

ealsticsearch安装

fir01
 fir01
发布于 2015/04/11 08:45
字数 153
阅读 102
收藏 3

1、安装控制台./bin/plugin -i elasticsearch/marvel/latest
./bin/plugin -i elasticsearch/head/latest
禁用它使用echo 'marvel.agent.enabled: false'  >> ./config/elasticsearch.yml
2、启动./bin/elasticsearch,如果要保护进程运行./bin/elasticsearch -d
3、关闭,直接按ctrl+c或者使用curl -XPOST 'http://localhost:9200/_shutdown'
4、curl安装http://curl.haxx.se/download/curl-7.20.0-win64-ssl-sspi.zip
,然后导入bin path。
curl 测试安装curl http://localhost:9200/?pretty
5、安装head,HQ,这是两款免费的监控软件。可以直接下载按后解压到,HQ安装可以在plugins新建文件夹plugins/HQ/_site/所有源文件。head雷同

© 著作权归作者所有

共有 人打赏支持
上一篇: javaFX备忘录
下一篇: javaFX的备忘录
fir01
粉丝 20
博文 110
码字总数 34117
作品 0
长沙
项目经理
私信 提问
ELK索引备份,迁移及恢复

由于公司的elasticsearch集群只是用了两台服务器。只要一台服务器数据丢失elasticsearch将丢失一半数据。所以数据的备份恢复就相当重要。elasticsearch 快照和恢复模块可以创建单个索引或者整...

irow10
2016/12/07
0
0
[Success]Elasticsearch介绍和安装+ik

一.Elasticsearch介绍和安装 SprignBoot整合Spring Data Elasticsearch 以及使用 1.1.简介 1.1.1.Elastic Elastic官网:https://www.elastic.co/cn/ Elastic有一条完整的产品线:Elasticsear......

Armymans
11/12
0
0
Elasticsearch重要文章之三:重要配置项的修改

Elasticsearch已经有很好的默认值,特别是涉及到性能相关的配置或者选项。如果你有什么拿不准的,最好就不要动它。我们已经目睹了数十个因为错误的设置而导致集群毁灭,因为它的管理者总认为...

Contac
2016/01/07
2.1K
0
ElasticSearch大数据分布式弹性搜索引擎使用—从0到1

阅读目录: 背景 安装 下载elasticsearch servicewrapper 包 elasticsearch servicewrapper开源包的配置小bug servicewrapper安装 chkconfig -add 加入linux启动服务列表 查找、下载rpm包 、...

王清培
06/26
0
0

没有更多内容

加载失败,请刷新页面

加载更多
phper必知必会(二)

  1.说说你对进程,线程以及协程的理解      进程:是系统进行资源分配和调度的基本单位,是基本操作系统结构的基础。进程是程序基本执行的实体。进程与进程之间是独立的,拥有完全独立...

SEOwhywhy
12分钟前
0
0
Ubuntu16.04下安装docker

[TOC] 本文开发环境为Ubuntu 16.04 LTS 64位系统,通过apt的docker官方源安装最新的Docker CE(Community Edition),即Docker社区版,是开发人员和小型团队的理想选择。 1. 开始安装 1.1 由于...

豫华商
今天
10
0
使用XShell工具密钥认证登录Linux系统

如果你是一名Linux运维,那么Linux服务器的系统安全问题,可能是你要考虑的,而系统登录方式有两种,密码和密钥。哪一种更加安全呢? 无疑是后者! 这里我为大家分享用Xshell利器使用密钥的方...

dragon_tech
今天
8
0
day178-2018-12-15-英语流利阅读-待学习

“真蛛奶茶”了解一下?蜘蛛也会产奶了 Lala 2018-12-15 1.今日导读 “蛋白质含量是牛奶的 4 倍,并有着更低的脂肪和含糖量”,听起来诱人又美味的并不是羊奶或豆奶,而是你可能打死都想不到...

飞鱼说编程
今天
13
0
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents

场景重现 npm install --verbose 安装依赖的时,出现如下警告 npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):npm WARN notsup SKIPPING OPTIONA......

taadis
今天
2
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部