Python版本升级

原创
2019/12/17 10:40
阅读数 118

在学习的过程中,总是遇到系统上默认安装的Python版本是2.7.5,而我们实际上要求在Python3的环境下去运行程序的。这个时候该如何升级?

  1. 下载新的版本
wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz
  1. 解压缩
tar -zxvf Python-3.5.2.tgz
  1. 进入解压缩后的目录,安装配置:
cd Python-3.5.2/
./configure
  1. 执行 ./configure 时,如果报错:
configure: error: no acceptable C compiler found in $PATH
说明没有安装合适的编译器。这时,需要安装/升级 gcc 及其它依赖包。
# yum install make gcc gcc-c++ 
  1. 完成之后,重新执行:
 ./configure
make
make install
  1. 验证
python -v
python3 -v
  1. 安装pip3
# 下载,CentOS系统直接下载pip3解决问题
yum install python3-pip
# 查看具体的版本
pip3 --version

上述是在云服务器上安装 Python3 的,在MacOS下面安装 Python3 很方便的

brew install python3
展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部