centos6.5升级内核到3.10.28
centos6.5升级内核到3.10.28
求学ing 发表于2年前
centos6.5升级内核到3.10.28
  • 发表于 2年前
  • 阅读 1840
  • 收藏 8
  • 点赞 1
  • 评论 1

标题:腾讯云 新注册用户域名抢购1元起>>>   

摘要: 最近在玩docker需要升级内核

本文转载自:http://ljf.me/  

网上有不少升级CentOS内核的文章,如《CentOS 6.5 升级内核到 3.10.28,大部分都是下载源码编译,有点麻烦。

在yum的ELRepo源中,有mainline(3.13.1)、long-term(3.10.28)这2个内核版本,考虑到long-term更稳定,会长期更新,所以选择这个版本。

1、导入public key

rpm --import https://www.elrepo.org/RPM-GPG-KEY-elrepo.org

2、安装ELRepo到CentOS-6.5中

rpm -ivh http://www.elrepo.org/elrepo-release-6-5.el6.elrepo.noarch.rpm

3、安装**kernel-lt(lt=long-term)**

yum --enablerepo=elrepo-kernel install kernel-lt -y

或者安装kernel-ml(ml=mainline)

yum --enablerepo=elrepo-kernel install kernel-ml -y

4、编辑grub.conf文件,修改Grub引导顺序

vim /etc/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/sda1
#          initrd /boot/initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title CentOS (3.10.28-1.el6.elrepo.x86_64)
        root (hd0,0)
        kernel /boot/vmlinuz-3.10.28-1.el6.elrepo.x86_64 ro root=UUID=0a05411f-16f2-4d69-beb0-2db4cefd3613 rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_MD crashkernel=auto.UTF-8 rd_NO_LVM rd_NO_DM rhgb quiet
        initrd /boot/initramfs-3.10.28-1.el6.elrepo.x86_64.img
title CentOS (2.6.32-431.3.1.el6.x86_64)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.32-431.3.1.el6.x86_64 ro root=UUID=0a05411f-16f2-4d69-beb0-2db4cefd3613 rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_MD crashkernel=auto.UTF-8 rd_NO_LVM rd_NO_DM rhgb quiet
        initrd /boot/initramfs-2.6.32-431.3.1.el6.x86_64.img
title CentOS (2.6.32-431.el6.x86_64)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.32-431.el6.x86_64 ro root=UUID=0a05411f-16f2-4d69-beb0-2db4cefd3613 rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_MD crashkernel=auto.UTF-8 rd_NO_LVM rd_NO_DM rhgb quiet
        initrd /boot/initramfs-2.6.32-431.el6.x86_64.img

确认刚安装好的内核在哪个位置,然后设置default值(从0开始),一般新安装的内核在第一个位置,所以设置default=0。 5、重启,查看内核版本号

[root@dev ~]# uname -r 3.10.28-1.el6.elrepo.x86_64


以下自己添加:

----------------centos6.5 安装 docker-----------------------------

运行docker Linux内核版本需要在3.8以上.(我的centos在没升级到3.10.28之前就安装了docker,使用的时候有问题比如exit命令退出容器会卡死)

直接使用命令: yum install docker-io   是会报错的!!!  提示:No package docker-io available.

需要安装yum 源 yum -y install http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

安装epel-release-6-8.noarch.rpm以后直接 yum install docker-io  就可以正常安装了!!


共有 人打赏支持
粉丝 11
博文 144
码字总数 72348
评论 (1)
lvlin
按照这样操作后升级内核,启动docker容易后无法在 docker容器中使用crond 服务,这个服务已经安装启动,但是写入计划任务后无法正常使用,脚本到了时间点不会自动执行,手动是能正常执行的
×
求学ing
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: