java.lang.UnsupportedClassVersionError: Bad versio

2016/12/09 11:21
阅读数 16
java.lang.UnsupportedClassVersionError: Bad version number in .class file

造成这种错误的原因是你的支持Tomcat运行的JDK版本与支持application运行的JDK版本不一致导致的.

那么如何解决上面的问题呢?

办法显而易见:把它们的JDK版本改成一致.

步骤如下:

1.Window --> Preferences -->Java --> compiler中的compiler compliance level对应的下拉菜单中选择JDK版本.

2.Window --> Preferences -->MyEclipse --> Servers -->Tomcat --> Tomcat n.x -->JDK中的Tomcat JDK name下的下拉菜单中选择自己电脑上安装的JDK版本(必须与步骤1中的JDK版本一致).

如果还是没有解决,不用着急,因为有些MyEclipse版本自带有JDK版本,所以也要将它改过来.

3.Window --> Preferences -->Java -->Installed JRES,然后在右边选择与步骤1和2版本一致的JDK版本,如果没有,可以自己添加.然后选中就可以了.

注:以上仅供参考,讲的不详细之外,请读者自己再去摸索摸索^_^

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部