一个异常:Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .c

2014/08/29 13:03
阅读数 249

今天在创建了一个工程,编译并部署到tomcat后,发现出现了java.lang.UnsupportedClassVersionError: Bad version number in .class file 异常,检查了一下我的MyEclipse6.0配置,发现在MyEclipse里面给Tomcat 配置的JDK是其默认的MyEclipse6.0 ,将其修改为JDK6.0 试了一下,结果OK, 所以就是这个问题引起。

       具体解决办法 :在myEclipse中改变编译器的方法

Window->Proerence->MyEclipse->Servers->Tomcat->Tomcat 6.x->JDK

在Tomcat JDK name中选择jdk1.6.0

PS:因为Tomcat6.0需要jdk1.6.0以上版本支持 , 但是MyEclipse6.0的jdk版本是5.0 的, 所以会出现这个异常。

       另外还有个地方最好也要设置最新版本JDK,

Window->Proerence->Java->Installed JARs->JDK .在这里可以添加需要的Jdk。

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部