Android studio 解决依赖冲突,统一版本-- gradle resolutionStrategy

原创
2018/10/19 15:05
阅读数 1.1K

可以使用此配置解决各种依赖问题,统一版本,如解决support lib问题:

`
//解决冲突 同一版本
configurations.all {
	resolutionStrategy.eachDependency { DependencyResolveDetails details ->
		def requested = details.requested
		if (requested.group == 'com.android.support') {
			if (!requested.name.startsWith("multidex")) {
				details.useVersion ANDROID_SUPPORT_LIB_VERSION
			}
		}
	}
}
`
展开阅读全文
加载中

作者的其它热门文章

打赏
0
0 收藏
分享
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部