文档章节

linux下nginx多版本php共存

china008
 china008
发布于 2015/08/26 15:48
字数 888
阅读 2241
收藏 7

应用环境


LNMP的环境,当前PHP版本5.3.8,遇到一个应用需求只支持PHP 5.2.x,又希望保持现有应用还是用PHP 5.3.8。也就是说需要两个版本的PHP同时存在,供nginx根据需要调用不同版本。


思路


Nginx是通过PHP-FastCGI与PHP交互的。而PHP-FastCGI运行后会通过文件、或本地端口两种方式进行监听,在Nginx中配置相应的FastCGI监听端口或文件即实现Nginx请求对PHP的解释。


既然PHP-FastCGI是监听端口和文件的,那就可以让不同版本的PHP-FastCGI同时运行,监听不同的端口或文件,Nginx中根据需求配置调用不同的PHP-FastCGI端口或文件,即可实现不同版本PHP共存了。


配置记录


下面记录简单的配置流程,基于已经安装了lnmp的debian环境。当前版本的PHP是5.3.8,位于/usr/local/php。


1.下载PHP-5.2.14及相关的FPM、autoconf组件:


帮助

1

2

3

4

mkdir ~/php5.2

cd ~/php5.2

wget -c http://museum.php.net/php5/php-5.2.14.tar.gz

wget -c http://php-fpm.org/downloads/php-5.2.14-fpm-0.5.14.diff.gz

2.解压PHP-5.2.14,并打上PHP-FPM的补丁:


帮助

1

2

tar zxvf php-5.2.14.tar.gz

gzip -cd php-5.2.14-fpm-0.5.14.diff.gz | patch -d php-5.2.14 -p1

3.如果你已经通过lnmp安装,应该已经安装好了autoconf,如果没有,请自行下载并编译autoconf-2.13,然后设置autoconf环境变量:


帮助

1

2

export PHP_AUTOCONF=/usr/local/autoconf-2.13/bin/autoconf¬

export PHP_AUTOHEADER=/usr/local/autoconf-2.13/bin/autoheader

3.编译安装PHP-5.2.14在新的路径(/usr/local/php-5.2.14)下,注意–prefix、–with-config-file-path的路径,并且打开fastcgi和fpm选项:


帮助

1

2

3

4

5

cd php-5.2.14/

./buildconf --force

./configure --prefix=/usr/local/php-5.2.14 --with-config-file-path=/usr/local/php-5.2.14/etc --with-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --enable-fastcgi --enable-fpm

make ZEND_EXTRA_LIBS='-liconv'

make install

4.设置/usr/local/php-5.2.14/etc/php-fpm.conf,监听端口:


帮助

1

<value name="listen_address">127.0.0.1:9001</value>

或者监听文件:

帮助

1

<value name="listen_address">/path/to/unix/socket</value>

其他参数根据服务器环境和需求自行定制。

5.启动php-fpm,以后可以通过php-fpm进行管理:


帮助

1

/usr/local/php-5.2.14/sbin/php-fpm start

字php5.3.3后,php已经将php-fpm继承到php中,而且内置的php-fpm默认不支持(start|stop|reload)的平滑启动参数,需要使用官方源代码中提供的启动脚本来控制:

帮助

1

2

3

cp -f (php -5.3.x-source-dir)/sapi/fpm/init.d.php-fpm /etc/init.d/php-fpm

chmod 755 /etc/init.d/php-fpm

/etc/init.d/php-fpm start

php-fpm支持的操作:


start,启动PHP的FastCGI进程。

stop,强制终止PHP的FastCGI进程。

quit,平滑终止PHP的FastCGI进程。

restart, 重启PHP的FastCGI进程。

reload, 重新加载PHP的php.ini。

logrotate, 重新启用log文件。

5.3.3的php-fpm脚本支持的操作:start|stop|force-quit|restart|reload|status


6.配置好PHP-5.2.14的php.ini,重新加载生效:


帮助

1

2

vi /usr/local/php-5.2.14/etc/php.ini

/usr/local/php-5.2.14/sbin/php-fpm reload

7.修改nginx配置,对需要的服务配置使用PHP-5.2.14:


帮助

1

2

3

4

5

6

location ~ .*.(php|php5)?$

        {

            fastcgi_pass  127.0.0.1:9001;

            fastcgi_index index.php;

            include fcgi.conf;

        }

8.记录一下自己编译php5.5.10使用的配置


帮助

1

./configure --prefix=/usr/local/php-5.5.10 --with-config-file-path=/usr/local/php-5.5.10/etc --with-mysql=mysqlnd --with-mysqli=mysqlnd --with-bz2 --with-curl=/usr/bin --enable-ftp --enable-sockets --disable-ipv6 --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr/local --with-freetype-dir=/usr/local --enable-gd-native-ttf --with-iconv-dir=/usr/local --enable-mbstring --enable-calendar --with-gettext --with-libxml-dir=/usr/local --with-zlib --with-pdo-mysql=mysqlnd --enable-dom --enable-xml --enable-fpm --with-libdir=lib64 --with-mcrypt=/usr/bin --enable-zip --enable-soap --enable-mbstring  --with-gd --with-openssl --enable-pcntl --with-xmlrpc --enable-opcache

参考资料:


http://ixdba.blog.51cto.com/2895551/806622

http://www.yinfor.com/blog/archives/2008/05/install_zend_optimizer_33_on_c.html

http://ideas.spkcn.com/technology/php-technology/133.html

http://zhangxugg-163-com.iteye.com/blog/1894990

Posted in linux, php | 1 Response


本文转载自:http://blog.saymoon.com/2012/09/linuxnginx_multi_version_php/

共有 人打赏支持
china008
粉丝 5
博文 286
码字总数 30406
作品 0
海淀
私信 提问
linux下多版本php共存的原理、方法

服务器当前PHP版本5.4,新项目中使用了Laravel,PHP版本最低要求5.6。希望保持现有应用同时使用PHP5.6.*。也就是说需要两个版本的PHP同时存在,供nginx根据需要调用不同版本。 一、原理: Ng...

zzc052
06/29
0
0
epii/epii-server

EpiiServer是什么 EpiiServer是一个简单易用的基于Php的部署工具。它能帮助开发人员迅速的构建php+nginx多应用部署环境,帮助测试人员构建测试环境。 特性: 多应用快速部署,域名自动生成。 ...

epii
08/14
0
0
wdcp_v3.2 正式版发布,Linux 服务器管理系统

经过近两周多时间的内测,wdcpv3.2正式版本,终于可以和大家见面了 在此,感谢那些参与内测的小伙伴们,有你们的参与,wdcp必将更加完美 v3.2版本,最大的亮点,自然是大家期待以久的两大功能...

wdlinuxcn
2017/05/10
859
8
OneinStack多版本PHP共存

基于《OneinStack》一键PHP/JAVA安装工具中lnmp模式,很多用户希望一个网站运行在php5.4,另一个网站运行在php7,甚至更多版本的php,那么一台服务器上同时支持多个PHP版本应该如何做呢? 1、...

linuxprobe16
2016/11/29
9
0
EpiiServer 更快捷更方便的php+nginx环境定制化方案

EpiiServer是什么 更快捷更方便的php+nginx多应用部署环境。 github仓库首页 https://github.com/epaii/epii-server gitee仓库 https://gitee.com/epii/epii-server 特性: 多应用快速部署,...

tianliangle
08/09
0
0

没有更多内容

加载失败,请刷新页面

加载更多

apache顶级项目(二) - B~C

apache顶级项目(二) - B~C https://www.apache.org/ Bahir Apache Bahir provides extensions to multiple distributed analytic platforms, extending their reach with a diversity of s......

晨猫
今天
1
0
day152-2018-11-19-英语流利阅读

“超级食物”竟然是营销噱头? Daniel 2018-11-19 1.今日导读 近几年来,超级食物 superfoods 开始逐渐走红。不难发现,越来越多的轻食餐厅也在不断推出以超级食物为主打食材的健康料理,像是...

飞鱼说编程
今天
7
0
SpringBoot源码:启动过程分析(二)

接着上篇继续分析 SpringBoot 的启动过程。 SpringBoot的版本为:2.1.0 release,最新版本。 一.时序图 一样的,我们先把时序图贴上来,方便理解: 二.源码分析 回顾一下,前面我们分析到了下...

Jacktanger
昨天
3
0
Apache防盗链配置,Directory访问控制,FilesMatch进行访问控制

防盗链配置 通过限制referer来实现防盗链的功能 配置前,使用curl -e 指定referer [root@test-a test-webroot]# curl -e "http://www.test.com/1.html" -x127.0.0.1:80 "www.test.com/1.jpg......

野雪球
昨天
5
0
RxJava threading

因为Rx针对异步系统设计,并且Rx也自然支持多线程,所以新的Rx开发人员有时会假设Rx默认是多线程的。在其他任何事情之前,重要的是澄清Rx默认是单线程的。 除非另有说明,否则每次调用onNex...

woshixin
昨天
2
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部