hadoop异常
hadoop异常
剪爱star 发表于6个月前
hadoop异常
  • 发表于 6个月前
  • 阅读 1
  • 收藏 0
  • 点赞 0
  • 评论 0

标题:腾讯云 新注册用户域名抢购1元起>>>   

摘要: http://blog.csdn.net/lbr2008/article/details/52794063

1.主机无法访问虚拟机 hadoop centos

/sbin/iptables -I INPUT -p tcp --dport 50070 -j ACCEPT

然后保存: /etc/rc.d/init.d/iptables save 重启防火墙 /etc/init.d/iptables restart

###2. WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable

解决方式:进入hadoop安装目录,lib/native

用ldd命令查看依赖库:ldd libhadoop.so.1.0.0  


会输出如下信息:

./libhadoop.so.1.0.0: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./libhadoop.so.1.0.0)
	linux-vdso.so.1 =>  (0x00007ffe548c8000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f2a878a6000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f2a87511000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003b49600000)

可以看到依赖的都是/lib64/的动态库,所以不是64位/32位问题。但是看到报错,GLIBC_2.14找不到,现在检查系统的glibc库, ldd --version即可检查。 参看

共有 人打赏支持
粉丝 0
博文 2
码字总数 20159
×
剪爱star
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: