ubuntu下make cowboy出现的依赖crypto问题
ubuntu下make cowboy出现的依赖crypto问题
采芹人 发表于2年前
ubuntu下make cowboy出现的依赖crypto问题
  • 发表于 2年前
  • 阅读 28
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 十分钟定制你的第一个小程序>>>   

cowboy官方教程是用relx来管理代码,笔者在ubuntu下make时,一直出现一个错误,导致编译不成功,如下图所示:

crypto模块与openssl不兼容,解决办法,先重装openssl,再重装erlang,重装时记得开启hipe

apt-get install ncurses-devel
./configure --with-ssl=/usr/local/ssl --enable-threads --enable-smp-support --enable-kernel-poll --enable-hipe --without-javac

具体操作可见:http://www.cnblogs.com/getong/p/3515679.html

标签: cowboy crypto
共有 人打赏支持
粉丝 2
博文 8
码字总数 2278
作品 1
×
采芹人
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: