Fedora21安装ZendServer之后yum报错

原创
2014/12/26 00:22
阅读数 140

Fedora21安装ZendServer之后yum坏掉了...运行说

pycurl: libcurl link-time version (7.20.1) is older than compile-time version (7.37.0)

在源中手动下在了相关包重装了也不行,在网上搜索了一下,最后找到一个帖子

http://netstu.5iunix.net/archives/201106-91/

按照贴中所说的方法尝试了一下:

[blu10ph@kuan-pc ~]$ rpm -qa | grep pycurl
python3-pycurl-7.19.3.1-5.fc21.x86_64
python-pycurl-7.19.3.1-5.fc21.x86_64

列出的这两个中第一个试了没有内容,直接发第二个

[blu10ph@kuan-pc ~]$ rpm -ql python-pycurl-7.19.3.1-5.fc21.x86_64 |grep  pycurl.so
/usr/lib64/python2.7/site-packages/pycurl.so

这个有内容,继续跟着上面的教程走

        鉴于最近不少人说博客被爬虫叼走,在这放个链接: http://my.oschina.net/blu10phcn/blog/360667  严重鄙视这种抄来抄去不加原文链接的行为,找点资料一搜一堆克隆的...

[blu10ph@kuan-pc ~]$ ldd /usr/lib64/python2.7/site-packages/pycurl.so
    linux-vdso.so.1 =>  (0x00007fff4b12f000)
    libcurl.so.4 => /usr/local/zend/lib/libcurl.so.4 (0x00007fa915658000)
    libpython2.7.so.1.0 => /lib64/libpython2.7.so.1.0 (0x00007fa915289000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fa91506d000)
    libc.so.6 => /lib64/libc.so.6 (0x00007fa914cb0000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007fa914aac000)
    libssl.so.0.9.8 => /usr/local/zend/lib/libssl.so.0.9.8 (0x00007fa91495b000)
    libcrypto.so.0.9.8 => /usr/local/zend/lib/libcrypto.so.0.9.8 (0x00007fa9146df000)
    libldap-2.4.so.2 => /usr/local/zend/lib/libldap-2.4.so.2 (0x00007fa914588000)
    librt.so.1 => /lib64/librt.so.1 (0x00007fa91437f000)
    libutil.so.1 => /lib64/libutil.so.1 (0x00007fa91417c000)
    libm.so.6 => /lib64/libm.so.6 (0x00007fa913e74000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fa9159d8000)
    liblber-2.4.so.2 => /usr/local/zend/lib/liblber-2.4.so.2 (0x00007fa913d66000)
    libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fa913b4c000)

果然有连接到Zend的库,照着帖子的方法修改了下,大体上是在/etc/ld.so.conf.d/下新建了个.conf的文件,添加原来的lib64的路径(我装的64位,32位是lib)

[blu10ph@kuan-pc ~]$ sudo gedit /etc/ld.so.conf.d/loadpycurl.conf
......此处省略若干不相关信息......
[blu10ph@kuan-pc ~]$ sudo ldconfig /etc/ld.so.conf.d/loadpycurl.conf 
ldconfig: /usr/local/zend/lib/libpq.so.5 不是符号连接

libpq.so.5这个错误暂时不知道是怎么回事,先忽略它...

[blu10ph@kuan-pc ~]$ yum --help
已加载插件:langpacks
Usage: yum [options] COMMAND

List of Commands:

autoremove     Remove leaf packages
check          检查 RPM 数据库问题
check-update   检查是否有可用的软件包更新

赞!!!!!!!!!!!!

顺利解决,希望能帮到遇到同样错误的人

感觉Fedora的中文资料有点少阿,难道大多用Fedora的都是英语倍儿棒的大牛?~

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部