文档章节

linux系统安装OFED(infiniband)

B
 BaoLinChuan
发布于 2014/04/20 22:47
字数 14653
阅读 2173
收藏 1

计算节点安装OFED

 

scientific linux5.8 x86_64

1.查看系统系统:

[root@localhost ~]# cat /etc/redhat-release   

Scientific Linux release 5.8 (Boron)

[root@localhost ~]# uname -a

Linux localhost.localdomain 2.6.18-308.1.1.el5 #1 SMP Thu Mar 8 09:54:23 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

 

2.查看分区信息

[root@localhost ~]# df -h

 

Filesystem            Size  Used Avail Use% Mounted on

/dev/sda6             1.5T  776M  1.5T   1% /

/dev/sda5             9.7G  2.7G  6.6G  29% /usr

/dev/sda3              39G  177M   37G   1% /home

/dev/sda1             487M   18M  444M   4% /boot

tmpfs                  16G     0   16G   0% /dev/shm

/dev/sr1              4.1G  4.1G     0 100% /media

3.infinband硬件信息Mellanox

 

[root@localhost ~]# lspci |grep Mellanox

04:00.0 Network controller: Mellanox Technologies MT27500 Family [ConnectX-3]

 

4.解决依赖包:挂在使用本地yum

 

1.备份分并删除/etc/yum.repo.d/目录下的yum配置文件,

2.新建一个本地源配置文件123.repo,文件内容如下

[root@localhost ~]# cat /etc/yum.repos.d/123.repo

[dvdserver]

name=yumserver

baseurl=file:///media/SL

enabled=1

gpgcheck=0

 

3当然你必须使用mount挂在光盘到/media

4.解决依赖包

1gcc-c++

yum -y install gcc-c++

Loaded plugins: kernel-module

dvdserver                                                | 1.3 kB     00:00    

dvdserver/primary                                        | 1.0 MB     00:00    

dvdserver                                                             3725/3725

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package gcc-c++.x86_64 0:4.1.2-52.el5 set to be updated

--> Processing Dependency: libstdc++-devel = 4.1.2-52.el5 for package: gcc-c++

--> Processing Dependency: gcc = 4.1.2-52.el5 for package: gcc-c++

--> Running transaction check

---> Package gcc.x86_64 0:4.1.2-52.el5 set to be updated

--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc

---> Package libstdc++-devel.x86_64 0:4.1.2-52.el5 set to be updated

dvdserver/filelists                                      | 3.4 MB     00:01    

--> Running transaction check

---> Package glibc-devel.x86_64 0:2.5-81.el5_8.1 set to be updated

--> Processing Dependency: glibc-headers = 2.5-81.el5_8.1 for package: glibc-devel

--> Processing Dependency: glibc-headers for package: glibc-devel

--> Running transaction check

---> Package glibc-headers.x86_64 0:2.5-81.el5_8.1 set to be updated

--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers

--> Processing Dependency: kernel-headers for package: glibc-headers

--> Running transaction check

---> Package kernel-headers.x86_64 0:2.6.18-308.1.1.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package              Arch        Version                  Repository      Size

================================================================================

Installing:

 gcc-c++              x86_64      4.1.2-52.el5           dvdserver      3.8 M

Installing for dependencies:

 gcc                  x86_64      4.1.2-52.el5           dvdserver      5.3 M

 glibc-devel          x86_64      2.5-81.el5_8.1           dvdserver      2.4 M

 glibc-headers        x86_64      2.5-81.el5_8.1           dvdserver      597 k

 kernel-headers       x86_64      2.6.18-308.1.1.el5       dvdserver      1.4 M

 libstdc++-devel      x86_64      4.1.2-52.el5             dvdserver      2.8 M

 

Transaction Summary

================================================================================

Install       6 Package(s)

Upgrade       0 Package(s)

 

Total download size: 16 M

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           1.5 GB/s |  16 MB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : kernel-headers                                           1/6

  Installing     : glibc-headers                                            2/6

  Installing     : glibc-devel                                              3/6

  Installing     : libstdc++-devel                                          4/6

  Installing     : gcc                                                      5/6

  Installing     : gcc-c++                                                  6/6

 

Installed:

  gcc-c++.x86_64 0:4.1.2-52.el5                                                

 

Dependency Installed:

  gcc.x86_64 0:4.1.2-52.el5                                                     

  glibc-devel.x86_64 0:2.5-81.el5_8.1                                          

  glibc-headers.x86_64 0:2.5-81.el5_8.1                                        

  kernel-headers.x86_64 0:2.6.18-308.1.1.el5                                   

  libstdc++-devel.x86_64 0:4.1.2-52.el5                                        

 

Complete!

 

 

 

2glib

[root@localhost ~]# yum -y install glib

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package glib.i386 1:1.2.10-20.el5 set to be updated

---> Package glib.x86_64 1:1.2.10-20.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package      Arch           Version                    Repository         Size

================================================================================

Installing:

 glib         i386           1:1.2.10-20.el5            dvdserver         137 k

 glib         x86_64         1:1.2.10-20.el5            dvdserver         144 k

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 281 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           159 MB/s | 281 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : glib                                                     1/2

  Installing     : glib                                                     2/2

 

Installed:

  glib.i386 1:1.2.10-20.el5             glib.x86_64 1:1.2.10-20.el5           

 

Complete!

 

(3) glib-devel

[root@localhost ~]# yum -y install glib-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package glib-devel.i386 1:1.2.10-20.el5 set to be updated

---> Package glib-devel.x86_64 1:1.2.10-20.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package           Arch          Version                 Repository        Size

================================================================================

Installing:

 glib-devel        i386          1:1.2.10-20.el5         dvdserver         39 k

 glib-devel        x86_64        1:1.2.10-20.el5         dvdserver         39 k

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 77 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                            44 MB/s |  77 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : glib-devel                                               1/2

  Installing     : glib-devel                                               2/2

 

Installed:

  glib-devel.i386 1:1.2.10-20.el5       glib-devel.x86_64 1:1.2.10-20.el5     

 

Complete!

 

 

[root@localhost ~]# yum -y install kernel-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package kernel-devel.x86_64 0:2.6.18-308.1.1.el5 set to be installed

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package            Arch         Version                  Repository       Size

================================================================================

Installing:

 kernel-devel       x86_64       2.6.18-308.1.1.el5       dvdserver       5.7 M

 

Transaction Summary

================================================================================

Install       1 Package(s)

Upgrade       0 Package(s)

 

Total download size: 5.7 M

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : kernel-devel                                             1/1

 

Installed:

  kernel-devel.x86_64 0:2.6.18-308.1.1.el5                                     

 

Complete!

 

(4)zilb-devel

[root@localhost ~]# yum -y install zlib-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package zlib-devel.i386 0:1.2.3-4.el5 set to be updated

---> Package zlib-devel.x86_64 0:1.2.3-4.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package            Arch           Version              Repository         Size

================================================================================

Installing:

 zlib-devel         i386           1.2.3-4.el5          dvdserver         101 k

 zlib-devel         x86_64         1.2.3-4.el5          dvdserver         103 k

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 204 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           743 kB/s | 204 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : zlib-devel                                               1/2

  Installing     : zlib-devel                                               2/2

 

Installed:

  zlib-devel.i386 0:1.2.3-4.el5         zlib-devel.x86_64 0:1.2.3-4.el5       

 

Complete!

 

(5)rpm-build

[root@localhost ~]# yum -y install rpm-build

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package rpm-build.x86_64 0:4.4.2.3-28.el5_8 set to be updated

--> Processing Dependency: xz for package: rpm-build

--> Processing Dependency: elfutils for package: rpm-build

--> Running transaction check

---> Package elfutils.x86_64 0:0.137-3.el5 set to be updated

--> Processing Dependency: elfutils-libs-x86_64 = 0.137-3.el5 for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.130)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.127)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.126)(64bit) for package: elfutils

--> Processing Dependency: libasm.so.1(ELFUTILS_1.0)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.122)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1()(64bit) for package: elfutils

--> Processing Dependency: libasm.so.1()(64bit) for package: elfutils

---> Package xz.x86_64 0:4.999.9-0.3.beta.20091007git.el5 set to be updated

--> Processing Dependency: xz-libs = 4.999.9-0.3.beta.20091007git.el5 for package: xz

--> Processing Dependency: liblzma.so.0()(64bit) for package: xz

--> Running transaction check

---> Package elfutils-libs.x86_64 0:0.137-3.el5 set to be updated

---> Package xz-libs.x86_64 0:4.999.9-0.3.beta.20091007git.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package         Arch     Version                             Repository   Size

================================================================================

Installing:

 rpm-build       x86_64   4.4.2.3-28.el5_8                    dvdserver   303 k

Installing for dependencies:

 elfutils        x86_64   0.137-3.el5                         dvdserver   216 k

 elfutils-libs   x86_64   0.137-3.el5                         dvdserver   182 k

 xz              x86_64   4.999.9-0.3.beta.20091007git.el5    dvdserver   146 k

 xz-libs         x86_64   4.999.9-0.3.beta.20091007git.el5    dvdserver    94 k

 

Transaction Summary

================================================================================

Install       5 Package(s)

Upgrade       0 Package(s)

 

Total download size: 941 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           189 MB/s | 941 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : xz-libs                                                   1/5

  Installing     : xz                                                       2/5

  Installing     : elfutils-libs                                                3/5

  Installing     : elfutils                                                    4/5

  Installing     : rpm-build                                                  5/5

 

Installed:

  rpm-build.x86_64 0:4.4.2.3-28.el5_8                                          

 

Dependency Installed:

  elfutils.x86_64 0:0.137-3.el5                                                 

  elfutils-libs.x86_64 0:0.137-3.el5                                           

  xz.x86_64 0:4.999.9-0.3.beta.20091007git.el5                                 

  xz-libs.x86_64 0:4.999.9-0.3.beta.20091007git.el5                             

 

Complete!

 

(6)redhat-rpm-config

[root@localhost ~]# yum -y install redhat-rpm-config

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package redhat-rpm-config.noarch 0:8.0.45-32.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package                 Arch         Version             Repository       Size

================================================================================

Installing:

 redhat-rpm-config       noarch       8.0.45-32.el5       dvdserver        55 k

 

Transaction Summary

================================================================================

Install       1 Package(s)

Upgrade       0 Package(s)

 

Total download size: 55 k

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : redhat-rpm-config                                        1/1

 

Installed:

  redhat-rpm-config.noarch 0:8.0.45-32.el5                                     

 

Complete!

 

(7)tcl

[root@localhost ~]# yum -y install tcl

Loaded plugins: kernel-module

Setting up Install Process

Package tcl-8.4.13-4.el5.x86_64 already installed and latest version

Resolving Dependencies

--> Running transaction check

---> Package tcl.i386 0:8.4.13-4.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package       Arch           Version                 Repository           Size

================================================================================

Installing:

 tcl           i386           8.4.13-4.el5            dvdserver           956 k

 

Transaction Summary

================================================================================

Install       1 Package(s)

Upgrade       0 Package(s)

 

Total download size: 956 k

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : tcl                                                      1/1

 

Installed:

  tcl.i386 0:8.4.13-4.el5                                                      

 

Complete!

 

(8)tcl-devel

[root@localhost ~]# yum -y install tcl-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package tcl-devel.i386 0:8.4.13-4.el5 set to be updated

---> Package tcl-devel.x86_64 0:8.4.13-4.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package           Arch           Version               Repository         Size

================================================================================

Installing:

 tcl-devel         i386           8.4.13-4.el5          dvdserver         1.0 M

 tcl-devel         x86_64         8.4.13-4.el5          dvdserver         1.0 M

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 2.0 M

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           786 MB/s | 2.0 MB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : tcl-devel                                                1/2

  Installing     : tcl-devel                                                2/2

 

Installed:

  tcl-devel.i386 0:8.4.13-4.el5         tcl-devel.x86_64 0:8.4.13-4.el5       

 

Complete!

(9)libtool

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# yum -y install libtool

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package libtool.x86_64 0:1.5.22-7.el5_4 set to be updated

--> Processing Dependency: autoconf >= 2.50 for package: libtool

--> Processing Dependency: automake >= 1.4 for package: libtool

--> Running transaction check

---> Package autoconf.noarch 0:2.59-12 set to be updated

--> Processing Dependency: imake for package: autoconf

---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated

--> Running transaction check

---> Package imake.x86_64 0:1.0.2-3 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package          Arch           Version                Repository         Size

================================================================================

Installing:

 libtool          x86_64         1.5.22-7.el5_4         dvdserver         667 k

Installing for dependencies:

 autoconf         noarch         2.59-12                dvdserver         648 k

 automake         noarch         1.9.6-2.3.el5          dvdserver         476 k

 imake            x86_64         1.0.2-3                dvdserver         318 k

 

Transaction Summary

================================================================================

Install       4 Package(s)

Upgrade       0 Package(s)

 

Total download size: 2.1 M

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           681 MB/s | 2.1 MB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : imake                                                    1/4

  Installing     : autoconf                                                 2/4

  Installing     : automake                                                 3/4

  Installing     : libtool                                                  4/4

 

Installed:

  libtool.x86_64 0:1.5.22-7.el5_4                                              

 

Dependency Installed:

  autoconf.noarch 0:2.59-12           automake.noarch 0:1.9.6-2.3.el5         

  imake.x86_64 0:1.0.2-3             

 

Complete!

 

注意:计算节点到此依赖包安装完成.注意安装前一定要安装上诉依赖包,否则你等着报错包

 

5.安装驱动

mellanox官网下载对应操作系统的版本,本案例由于mellanox官网没有scientific linux5.8的相应驱动,只能下载red hat5.8的操作系统使用源代码当前操作系统编译安装

 MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64.tgz

值得注意的是这个驱动就算在Red Hat 5.8上安装最好系统是英文版,最好/usr目录10GB

 

1)解压到指定目录,进入/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# tar -xzvf MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64.tgz -C /usr/src/

 

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# cd /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/

 

 

 

目录文件如下

[root@localhost MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64]# ls

docs      mlnx_add_kernel_support.sh  repodata  src

firmware  mlnxofedinstall             RPMS      uninstall.sh

 

2)标准安装就报错了,如下

 

 

[root@localhost MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64]# ./mlnxofedinstall The 2.6.18-308.1.1.el5 kernel is installed, MLNX_OFED does not have drivers available for this kernel.

You can run mlnx_add_kernel_support.sh in order to to generate an MLNX_OFED package with drivers for this kernel.

 

 

根据提示添加kernel,当然也报错,不详细说了,没办法只有源代码了如下:进入源代码src/

 

[root@localhost MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64]# cd /usr/src/MLNX_O

FED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/

 

解压源代码包src/MLNX_OFED_SRC-1.5.3-4.0.42.tgz

解决方法:

3.解压出来的源代码目录如下,并执行源代码安装了

 

[root@localhost src]# cd MLNX_OFED_SRC-1.5.3-4.0.42

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# ls

BUILD_ID  install.pl  LICENSE  ofed.conf  RPMS  SRPMS  uninstall.sh

 

 

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# ./install.pl 执行脚本

OFED Distribution Software Installation Menu

 

   1) View OFED Installation Guide

   2) Install OFED Software  (安装OFED驱动)

   3) Show Installed Software

   4) Configure IPoIB         (配置Ib网卡)

   5) Uninstall OFED Software

 

   Q) Exit

 

Select Option [1-5]:2

OFED Distribution Software Installation Menu

 

   1) Basic (OFED modules and basic user level libraries)  (只是驱动)

   2) HPC (OFED modules and libraries, MPI and diagnostic tools)  (驱动和MPI工具)

   3) All packages (all of Basic, HPC)      (管理节点需要opensmd服务,选择个就对了)

   4) Customize  (自定义,如果你对这个infinband网络结构够了解选它吧)

   5) Packages required by VMA (IB and Eth)

   6) Packages required by VMA IB

   7) Packages required by VMA Eth

 

   Q) Exit

 

Select Option [1-7]:1

 

Below is the list of OFED packages that you have chosen

(some may have been added by the installer due to package dependencies):

 

ofed-scripts

libibverbs

libibverbs-utils

libibverbs-devel

libmthca

libmverbs

libmverbs-devel

libmlx4

libcxgb3

libnes

libipathverbs

librdmacm

librdmacm-utils

mstflint

ofed-docs

mlnx-ofa_kernel

kernel-mft

过程如下

Build ofed-scripts RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ofed-scripts-1.5.3-OFED.1.5.3.4.0.42.src.rpm

Install ofed-scripts RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/ofed-scripts-1.5.3-OFED.1.5.3.4.0.42.x86_64.rpm

Build libibverbs RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libibverbs-1.1.5mlnx2-1.src.rpm

Install libibverbs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-1.1.5mlnx2-1.x86_64.rpm

Install libibverbs-utils RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-utils-1.1.5mlnx2-1.x86_64.rpm

Install libibverbs-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-devel-1.1.5mlnx2-1.x86_64.rpm

Build libmthca RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libmthca-1.0.6mlnx1-0.1.gbe5eef3.src.rpm

Install libmthca RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmthca-1.0.6mlnx1-0.1.gbe5eef3.x86_64.rpm

Build libmverbs RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libmverbs-0.1.0-3.15.gd28970e.src.rpm

Install libmverbs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmverbs-0.1.0-3.15.gd28970e.x86_64.rpm

Install libmverbs-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmverbs-devel-0.1.0-3.15.gd28970e.x86_64.rpm

Build libmlx4 RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libmlx4-1.0.2mlnx6-1.src.rpm

Install libmlx4 RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmlx4-1.0.2mlnx6-1.x86_64.rpm

Build libcxgb3 RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libcxgb3-1.3.1-1.src.rpm

Install libcxgb3 RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libcxgb3-1.3.1-1.x86_64.rpm

Build libnes RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libnes-1.1.1mlnx1-1.src.rpm

Install libnes RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libnes-1.1.1mlnx1-1.x86_64.rpm

Build libipathverbs RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libipathverbs-1.2mlnx1-1.src.rpm

Install libipathverbs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libipathverbs-1.2mlnx1-1.x86_64.rpm

Build librdmacm RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/librdmacm-1.0.15-1.src.rpm

Install librdmacm RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/librdmacm-1.0.15-1.x86_64.rpm

Install librdmacm-utils RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/librdmacm-utils-1.0.15-1.x86_64.rpm

Build mstflint RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/mstflint-1.4mlnx4-1.21.gd948ddd.src.rpm

Install mstflint RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/mstflint-1.4mlnx4-1.21.gd948ddd.x86_64.rpm

Build ofed-docs RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ofed-docs-1.5.3-OFED.1.5.3.4.0.42.src.rpm

Install ofed-docs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/ofed-docs-1.5.3-OFED.1.5.3.4.0.42.x86_64.rpm

Build mlnx-ofa_kernel RPM

Running rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --nodeps --define '_dist .unsupported' --define 'configure_options   --with-core-mod --with-user_mad-mod --with-user_access-mod --with-addr_trans-mod --with-mthca-mod --with-mlx4-mod --with-mlx4_en-mod --with-mlx4_ib-mod --with-mlx4_vnic-mod --with-nes-mod --with-qib-mod --with-ipoib-mod' --define 'build_kernel_ib 1' --define 'build_kernel_ib_devel 1' --define 'KVERSION 2.6.18-308.1.1.el5' --define 'K_SRC /lib/modules/2.6.18-308.1.1.el5/build' --define 'network_dir /etc/sysconfig/network-scripts' --define '_prefix /usr' --define '__arch_install_post %{nil}' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.src.rpm

Install mlnx-ofa_kernel RPM:

Installing mlnx-ofa_kernel RPM

cmd: rpm -ivh  --nodeps /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.unsupported.x86_64.rpm

Preparing...                ##################################################

mlnx-ofa_kernel             ##################################################

Installing kmod-mlnx-ofa_kernel RPM

Preparing...                ##################################################

kmod-mlnx-ofa_kernel        ##################################################

Build kernel-mft RPM

Running rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'KVERSION 2.6.18-308.1.1.el5' --define 'K_SRC /lib/modules/2.6.18-308.1.1.el5/build' --define '_release 2.6.18_308.1.1.el5' --define 'debug_package %{nil}' --define '_prefix /usr' --define '__arch_install_post %{nil}' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/kernel-mft-2.7.1-7.src.rpm

Install kernel-mft RPM:

Running rpm -iv  --nodeps /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/kernel-mft-2.7.1-2.6.18_308.1.1.el5.x86_64.rpm

 

The default IPoIB interface configuration is based on DHCP.

Note that a special patch for DHCP is required for supporting IPoIB.

The patch is available under docs/dhcp

If you do not have DHCP, you must change this configuration in the following steps.

 

Do you want to configure ib0? [Y/n]:y          输入y配置你的ib卡文件

 

The current IPoIB configuration for ib0 is:

# Mellanox Technologies MT27500 Family [ConnectX-3]

DEVICE=ib0

BOOTPROTO=dhcp

HWADDR=80:00:00:48:FE:80:00:00:00:00:00:00:F4:52:14:03:00:0D:C1:A1

ONBOOT=no

HOTPLUG=no

DHCP_HOSTNAME=localhost.localdomain

 

Do you want to change this configuration? [y/N]:y    需要修改吗,当然y

 

Enter an IP Adress: 192.168.1.101        IP  

 

Enter the Netmask: 255.255.255.0          (掩码)

 

Enter the Network: 192.168.1.0             (网络)

 

Enter the Broadcast Adress: 192.168.1.255   (广播地址)

 

Start Device On Boot? [Y/n]:y  开机启动(依赖openibd服务)

 

Selected configuration:

DEVICE=ib0

IPADDR=192.168.1.101

NETMASK=255.255.255.0

NETWORK=192.168.1.0

BROADCAST=192.168.1.255

ONBOOT=yes

 

Do you want to save the selected configuration? [Y/n]:y   保存ib配置

 

Do you want to configure ib1? [Y/n]:n        根据你需求了,我没开

IPoIB interfaces configured successfully

Press any key to continue ...

Device (15b3:1003):

        03:00.0 Network controller [0207]: Mellanox Technologies MT27500 Family [ConnectX-3]

        Link Width: 8x

        PCI Link Speed: Unknown

 

 

Installation finished successfully.

Press any key to continue...

OFED Distribution Software Installation Menu

 

   1) View OFED Installation Guide

   2) Install OFED Software

   3) Show Installed Software

   4) Configure IPoIB

   5) Uninstall OFED Software

 

   Q) Exit

 

Select Option [1-5]:q   退出

Exiting

 

 

驱动基本安装完成了,哈哈完美........

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# chkconfig --level 3 openibd on

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# chkconfig --level 5 openibd on   设置开启启动服务

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# /etc/init.d/openibd restart      手动启动服务命令

Unloading HCA driver:                                      [  OK  ]

Loading HCA driver and Access Layer:                       [  OK  ]

Setting up InfiniBand network interfaces:

Bringing up interface ib0:                                 [  OK  ]

 

Determining IP information for ib1... failed.

Bringing up interface ib1:                                 [  OK  ]

Setting up service network . . .                           [  done  ]

查看ib状态卡信息

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# hca_self_test.ofed      

---- Performing Adapter Device Self Test ----

Number of CAs Detected ................. 1

PCI Device Check ....................... PASS

Kernel Arch ............................ x86_64

Host Driver Version .................... OFED-internal-1.5.3-4.0.42: 2.6.18-308.1.1.el5

Host Driver RPM Check .................. PASS

Firmware on CA #0 VPI .................. v2.11.550

Firmware Check on CA #0 (VPI) .......... NA

    REASON: NO required fw version

Host Driver Initialization ............. PASS

Number of CA Ports Active .............. 1

Port State of Port #1 on CA #0 (VPI)..... UP 4X FDR10 (InfiniBand)   看到这个就OK了,是否UP取决与infiniband网络中必须要有一个安装并开启opensmd服务

Port State of Port #2 on CA #0 (VPI)..... DOWN (InfiniBand)

Error Counter Check on CA #0 (VPI)...... PASS

Kernel Syslog Check .................... PASS

Node GUID on CA #0 (VPI) ............... f4:52:14:03:00:0d:c1:a0

------------------ DONE ---------------------

 

可以测试ping

rtt min/avg/max/mdev = 0.144/0.521/0.899/0.378 ms

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# ping 192.168.1.201

PING 192.168.1.201 (192.168.1.201) 56(84) bytes of data.

64 bytes from 192.168.1.201: icmp_seq=1 ttl=64 time=3.69 ms

64 bytes from 192.168.1.201: icmp_seq=2 ttl=64 time=0.104 ms

64 bytes from 192.168.1.201: icmp_seq=3 ttl=64 time=0.119 ms

 

--- 192.168.1.201 ping statistics ---

3 packets transmitted, 3 received, 0% packet loss, time 2001ms

rtt min/avg/max/mdev = 0.104/1.305/3.693/1.688 ms

 

Ok了啦,值得注意的是如果infiniband网络中必须要有一个安装并开启opensmd服务,否者你infiniband卡状态永远down

 

 

 

 

那我们看看管理节点安装了

scientific linux5.8 x86_64

1.查看系统系统:

[root@localhost ~]# cat /etc/redhat-release   

Scientific Linux release 5.8 (Boron)

[root@localhost ~]# uname -a

Linux localhost.localdomain 2.6.18-308.1.1.el5 #1 SMP Thu Mar 8 09:54:23 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

 

2.查看分区信息

[root@localhost ~]# df -h

 

Filesystem            Size  Used Avail Use% Mounted on

/dev/sda6             1.5T  776M  1.5T   1% /

/dev/sda5             9.7G  2.7G  6.6G  29% /usr

/dev/sda3              39G  177M   37G   1% /home

/dev/sda1             487M   18M  444M   4% /boot

tmpfs                  16G     0   16G   0% /dev/shm

/dev/sr1              4.1G  4.1G     0 100% /media

3.infinband硬件信息Mellanox

 

[root@localhost ~]# lspci |grep Mellanox

04:00.0 Network controller: Mellanox Technologies MT27500 Family [ConnectX-3]

 

4.解决依赖包:挂在使用本地yum

 

1.备份分并删除/etc/yum.repo.d/目录下的yum配置文件,

2.新建一个本地源配置文件123.repo,文件内容如下

[root@localhost ~]# cat /etc/yum.repos.d/123.repo

[dvdserver]

name=yumserver

baseurl=file:///media/SL

enabled=1

gpgcheck=0

 

3当然你必须使用mount挂在光盘到/media

4.解决依赖包

1gcc-c++

yum -y install gcc-c++

Loaded plugins: kernel-module

dvdserver                                                | 1.3 kB     00:00    

dvdserver/primary                                        | 1.0 MB     00:00    

dvdserver                                                             3725/3725

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package gcc-c++.x86_64 0:4.1.2-52.el5 set to be updated

--> Processing Dependency: libstdc++-devel = 4.1.2-52.el5 for package: gcc-c++

--> Processing Dependency: gcc = 4.1.2-52.el5 for package: gcc-c++

--> Running transaction check

---> Package gcc.x86_64 0:4.1.2-52.el5 set to be updated

--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc

---> Package libstdc++-devel.x86_64 0:4.1.2-52.el5 set to be updated

dvdserver/filelists                                      | 3.4 MB     00:01    

--> Running transaction check

---> Package glibc-devel.x86_64 0:2.5-81.el5_8.1 set to be updated

--> Processing Dependency: glibc-headers = 2.5-81.el5_8.1 for package: glibc-devel

--> Processing Dependency: glibc-headers for package: glibc-devel

--> Running transaction check

---> Package glibc-headers.x86_64 0:2.5-81.el5_8.1 set to be updated

--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers

--> Processing Dependency: kernel-headers for package: glibc-headers

--> Running transaction check

---> Package kernel-headers.x86_64 0:2.6.18-308.1.1.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package              Arch        Version                  Repository      Size

================================================================================

Installing:

 gcc-c++              x86_64      4.1.2-52.el5           dvdserver      3.8 M

Installing for dependencies:

 gcc                  x86_64      4.1.2-52.el5           dvdserver      5.3 M

 glibc-devel          x86_64      2.5-81.el5_8.1           dvdserver      2.4 M

 glibc-headers        x86_64      2.5-81.el5_8.1           dvdserver      597 k

 kernel-headers       x86_64      2.6.18-308.1.1.el5       dvdserver      1.4 M

 libstdc++-devel      x86_64      4.1.2-52.el5             dvdserver      2.8 M

 

Transaction Summary

================================================================================

Install       6 Package(s)

Upgrade       0 Package(s)

 

Total download size: 16 M

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           1.5 GB/s |  16 MB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : kernel-headers                                           1/6

  Installing     : glibc-headers                                            2/6

  Installing     : glibc-devel                                              3/6

  Installing     : libstdc++-devel                                          4/6

  Installing     : gcc                                                      5/6

  Installing     : gcc-c++                                                  6/6

 

Installed:

  gcc-c++.x86_64 0:4.1.2-52.el5                                                

 

Dependency Installed:

  gcc.x86_64 0:4.1.2-52.el5                                                    

  glibc-devel.x86_64 0:2.5-81.el5_8.1                                          

  glibc-headers.x86_64 0:2.5-81.el5_8.1                                        

  kernel-headers.x86_64 0:2.6.18-308.1.1.el5                                   

  libstdc++-devel.x86_64 0:4.1.2-52.el5                                        

 

Complete!

 

 

 

2glib

[root@localhost ~]# yum -y install glib

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package glib.i386 1:1.2.10-20.el5 set to be updated

---> Package glib.x86_64 1:1.2.10-20.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package      Arch           Version                    Repository         Size

================================================================================

Installing:

 glib         i386           1:1.2.10-20.el5            dvdserver         137 k

 glib         x86_64         1:1.2.10-20.el5            dvdserver         144 k

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 281 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           159 MB/s | 281 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : glib                                                     1/2

  Installing     : glib                                                     2/2

 

Installed:

  glib.i386 1:1.2.10-20.el5             glib.x86_64 1:1.2.10-20.el5           

 

Complete!

 

(3) glib-devel

[root@localhost ~]# yum -y install glib-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package glib-devel.i386 1:1.2.10-20.el5 set to be updated

---> Package glib-devel.x86_64 1:1.2.10-20.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package           Arch          Version                 Repository        Size

================================================================================

Installing:

 glib-devel        i386          1:1.2.10-20.el5         dvdserver         39 k

 glib-devel        x86_64        1:1.2.10-20.el5         dvdserver         39 k

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 77 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                            44 MB/s |  77 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : glib-devel                                               1/2

  Installing     : glib-devel                                               2/2

 

Installed:

  glib-devel.i386 1:1.2.10-20.el5       glib-devel.x86_64 1:1.2.10-20.el5     

 

Complete!

 

 

[root@localhost ~]# yum -y install kernel-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package kernel-devel.x86_64 0:2.6.18-308.1.1.el5 set to be installed

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package            Arch         Version                  Repository       Size

================================================================================

Installing:

 kernel-devel       x86_64       2.6.18-308.1.1.el5       dvdserver       5.7 M

 

Transaction Summary

================================================================================

Install       1 Package(s)

Upgrade       0 Package(s)

 

Total download size: 5.7 M

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : kernel-devel                                             1/1

 

Installed:

  kernel-devel.x86_64 0:2.6.18-308.1.1.el5                                     

 

Complete!

 

(4)zilb-devel

[root@localhost ~]# yum -y install zlib-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package zlib-devel.i386 0:1.2.3-4.el5 set to be updated

---> Package zlib-devel.x86_64 0:1.2.3-4.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package            Arch           Version              Repository         Size

================================================================================

Installing:

 zlib-devel         i386           1.2.3-4.el5          dvdserver         101 k

 zlib-devel         x86_64         1.2.3-4.el5          dvdserver         103 k

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 204 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           743 kB/s | 204 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : zlib-devel                                               1/2

  Installing     : zlib-devel                                               2/2

 

Installed:

  zlib-devel.i386 0:1.2.3-4.el5         zlib-devel.x86_64 0:1.2.3-4.el5       

 

Complete!

 

(5)rpm-build

[root@localhost ~]# yum -y install rpm-build

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package rpm-build.x86_64 0:4.4.2.3-28.el5_8 set to be updated

--> Processing Dependency: xz for package: rpm-build

--> Processing Dependency: elfutils for package: rpm-build

--> Running transaction check

---> Package elfutils.x86_64 0:0.137-3.el5 set to be updated

--> Processing Dependency: elfutils-libs-x86_64 = 0.137-3.el5 for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.130)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.127)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.126)(64bit) for package: elfutils

--> Processing Dependency: libasm.so.1(ELFUTILS_1.0)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1(ELFUTILS_0.122)(64bit) for package: elfutils

--> Processing Dependency: libdw.so.1()(64bit) for package: elfutils

--> Processing Dependency: libasm.so.1()(64bit) for package: elfutils

---> Package xz.x86_64 0:4.999.9-0.3.beta.20091007git.el5 set to be updated

--> Processing Dependency: xz-libs = 4.999.9-0.3.beta.20091007git.el5 for package: xz

--> Processing Dependency: liblzma.so.0()(64bit) for package: xz

--> Running transaction check

---> Package elfutils-libs.x86_64 0:0.137-3.el5 set to be updated

---> Package xz-libs.x86_64 0:4.999.9-0.3.beta.20091007git.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package         Arch     Version                             Repository   Size

================================================================================

Installing:

 rpm-build       x86_64   4.4.2.3-28.el5_8                    dvdserver   303 k

Installing for dependencies:

 elfutils        x86_64   0.137-3.el5                         dvdserver   216 k

 elfutils-libs   x86_64   0.137-3.el5                         dvdserver   182 k

 xz              x86_64   4.999.9-0.3.beta.20091007git.el5    dvdserver   146 k

 xz-libs         x86_64   4.999.9-0.3.beta.20091007git.el5    dvdserver    94 k

 

Transaction Summary

================================================================================

Install       5 Package(s)

Upgrade       0 Package(s)

 

Total download size: 941 k

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           189 MB/s | 941 kB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : xz-libs                                                   1/5

  Installing     : xz                                                       2/5

  Installing     : elfutils-libs                                                3/5

  Installing     : elfutils                                                    4/5

  Installing     : rpm-build                                                  5/5

 

Installed:

  rpm-build.x86_64 0:4.4.2.3-28.el5_8                                          

 

Dependency Installed:

  elfutils.x86_64 0:0.137-3.el5                                                 

  elfutils-libs.x86_64 0:0.137-3.el5                                           

  xz.x86_64 0:4.999.9-0.3.beta.20091007git.el5                                 

  xz-libs.x86_64 0:4.999.9-0.3.beta.20091007git.el5                             

 

Complete!

 

(6)redhat-rpm-config

[root@localhost ~]# yum -y install redhat-rpm-config

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package redhat-rpm-config.noarch 0:8.0.45-32.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package                 Arch         Version             Repository       Size

================================================================================

Installing:

 redhat-rpm-config       noarch       8.0.45-32.el5       dvdserver        55 k

 

Transaction Summary

================================================================================

Install       1 Package(s)

Upgrade       0 Package(s)

 

Total download size: 55 k

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : redhat-rpm-config                                        1/1

 

Installed:

  redhat-rpm-config.noarch 0:8.0.45-32.el5                                     

 

Complete!

 

(7)tcl

[root@localhost ~]# yum -y install tcl

Loaded plugins: kernel-module

Setting up Install Process

Package tcl-8.4.13-4.el5.x86_64 already installed and latest version

Resolving Dependencies

--> Running transaction check

---> Package tcl.i386 0:8.4.13-4.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package       Arch           Version                 Repository           Size

================================================================================

Installing:

 tcl           i386           8.4.13-4.el5            dvdserver           956 k

 

Transaction Summary

================================================================================

Install       1 Package(s)

Upgrade       0 Package(s)

 

Total download size: 956 k

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : tcl                                                      1/1

 

Installed:

  tcl.i386 0:8.4.13-4.el5                                                      

 

Complete!

 

(8)tcl-devel

[root@localhost ~]# yum -y install tcl-devel

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package tcl-devel.i386 0:8.4.13-4.el5 set to be updated

---> Package tcl-devel.x86_64 0:8.4.13-4.el5 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package           Arch           Version               Repository         Size

================================================================================

Installing:

 tcl-devel         i386           8.4.13-4.el5          dvdserver         1.0 M

 tcl-devel         x86_64         8.4.13-4.el5          dvdserver         1.0 M

 

Transaction Summary

================================================================================

Install       2 Package(s)

Upgrade       0 Package(s)

 

Total download size: 2.0 M

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           786 MB/s | 2.0 MB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : tcl-devel                                                1/2

  Installing     : tcl-devel                                                2/2

 

Installed:

  tcl-devel.i386 0:8.4.13-4.el5         tcl-devel.x86_64 0:8.4.13-4.el5       

 

Complete!

(9)libtool

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# yum -y install libtool

Loaded plugins: kernel-module

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package libtool.x86_64 0:1.5.22-7.el5_4 set to be updated

--> Processing Dependency: autoconf >= 2.50 for package: libtool

--> Processing Dependency: automake >= 1.4 for package: libtool

--> Running transaction check

---> Package autoconf.noarch 0:2.59-12 set to be updated

--> Processing Dependency: imake for package: autoconf

---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated

--> Running transaction check

---> Package imake.x86_64 0:1.0.2-3 set to be updated

--> Finished Dependency Resolution

Beginning Kernel Module Plugin

Finished Kernel Module Plugin

 

Dependencies Resolved

 

================================================================================

 Package          Arch           Version                Repository         Size

================================================================================

Installing:

 libtool          x86_64         1.5.22-7.el5_4         dvdserver         667 k

Installing for dependencies:

 autoconf         noarch         2.59-12                dvdserver         648 k

 automake         noarch         1.9.6-2.3.el5          dvdserver         476 k

 imake            x86_64         1.0.2-3                dvdserver         318 k

 

Transaction Summary

================================================================================

Install       4 Package(s)

Upgrade       0 Package(s)

 

Total download size: 2.1 M

Downloading Packages:

--------------------------------------------------------------------------------

Total                                           681 MB/s | 2.1 MB     00:00    

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Test Succeeded

Running Transaction

  Installing     : imake                                                    1/4

  Installing     : autoconf                                                 2/4

  Installing     : automake                                                 3/4

  Installing     : libtool                                                  4/4

 

Installed:

  libtool.x86_64 0:1.5.22-7.el5_4                                              

 

Dependency Installed:

  autoconf.noarch 0:2.59-12           automake.noarch 0:1.9.6-2.3.el5         

  imake.x86_64 0:1.0.2-3            

 

Complete!

 

到此依赖包安装完成.注意安装前一定要安装上诉依赖包,否则你等着报错包

 

5.安装驱动

mellanox官网下载对应操作系统的版本,本案例由于mellanox官网没有scientific linux5.8的相应驱动,只能下载red hat5.8的操作系统使用源代码当前操作系统编译安装

 MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64.tgz

值得注意的是这个驱动就算在Red Hat 5.8上安装最好系统是英文版,最好/usr目录10GB

 

1)解压到指定目录,进入/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# tar -xzvf MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64.tgz -C /usr/src/

 

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# cd /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/

 

 

 

目录文件如下

[root@localhost MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64]# ls

docs      mlnx_add_kernel_support.sh  repodata  src

firmware  mlnxofedinstall             RPMS      uninstall.sh

 

2)标准安装就报错了,如下

 

 

[root@localhost MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64]# ./mlnxofedinstall The 2.6.18-308.1.1.el5 kernel is installed, MLNX_OFED does not have drivers available for this kernel.

You can run mlnx_add_kernel_support.sh in order to to generate an MLNX_OFED package with drivers for this kernel.

 

 

根据提示添加kernel,当然也报错,不详细说了,没办法只有源代码了如下:进入源代码src/

 

[root@localhost MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64]# cd /usr/src/MLNX_O

FED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/

 

解压源代码包src/MLNX_OFED_SRC-1.5.3-4.0.42.tgz

 

3)解压出来的源代码目录如下,并执行源代码安装了

 

[root@localhost src]# cd MLNX_OFED_SRC-1.5.3-4.0.42

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# ls

BUILD_ID  install.pl  LICENSE  ofed.conf  RPMS  SRPMS  uninstall.sh

 

4)执行源代码安装脚本

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# ./install.pl

OFED Distribution Software Installation Menu

 

   1) View OFED Installation Guide  查看菜单

   2) Install OFED Software   安装驱动

   3) Show Installed Software  显示驱动文件包

   4) Configure IPoIB   配置IB卡文件

   5) Uninstall OFED Software   卸载

 

   Q) Exit

 

Select Option [1-5]:2

OFED Distribution Software Installation Menu

 

   1) Basic (OFED modules and basic user level libraries)   基本

   2) HPC (OFED modules and libraries, MPI and diagnostic tools)基本+MPI

   3) All packages (all of Basic, HPC)   所有

   4) Customize    自定义

   5) Packages required by VMA (IB and Eth)

   6) Packages required by VMA IB

   7) Packages required by VMA Eth

 

   Q) Exit

 

Select Option [1-7]:3  所有

 

Please choose an implementation of MVAPICH2:

 

1) OFA (IB and iWARP)

2) uDAPL

Implementation [1]: 1

 

Enable ROMIO support [Y/n]: y

 

Enable shared library support [Y/n]: y

 

Enable Checkpoint-Restart support [y/N]: y

 

BLCR installation directory [or nothing if not installed]: /usr  (当上面选择)

注意:下面是需要安装的包文件,这个不是系统自带的包,是OFED中的软件包

libmlx4-debuginfo

libmverbs-devel

libmqe

libmqe-devel

libcxgb3

libcxgb3-devel

libcxgb3-debuginfo

libnes

libnes-devel-static

libnes-debuginfo

libipathverbs

libipathverbs-devel

libipathverbs-debuginfo

libibcm

libibcm-devel

libibcm-debuginfo

libibumad

libibumad-devel

libibumad-static

libibumad-debuginfo

libibmad

libibmad-devel

libibmad-static

libibmad-debuginfo

ibsim

ibsim-debuginfo

ibacm

librdmacm

librdmacm-utils

librdmacm-devel

librdmacm-debuginfo

libsdp

libsdp-devel

libsdp-debuginfo

compat-dapl

compat-dapl-devel

dapl

dapl-devel

dapl-devel-static

dapl-utils

dapl-debuginfo

perftest

mstflint

sdpnetstat

srptools

rds-tools

rds-devel

ibutils     本次安装脚本安装在此处将报错:并终止,后续需手工安装

infiniband-diags

qperf

qperf-debuginfo

ofed-docs

openshmem

mpi-selector

openmpi_gcc

bupc

infinipath-psm

infinipath-psm-devel

mvapich2_gcc

mpitests_mvapich2_gcc

mpitests_openmpi_gcc     (到这里知道我们需要安装那些包,这是我们手工安装的依据)

 

Uninstalling the previous version of OFED   编译安装过程如下

Install ofed-scripts RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/ofed-scripts-1.5.3-OFED.1.5.3.4.0.42.x86_64.rpm

Build mlnx-ofa_kernel RPM

Running rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --nodeps --define '_dist .unsupported' --define 'configure_options   --with-core-mod --with-user_mad-mod --with-user_access-mod --with-addr_trans-mod --with-mthca-mod --with-mlx4-mod --with-mlx4_en-mod --with-mlx4_ib-mod --with-mlx4_vnic-mod --with-nes-mod --with-qib-mod --with-ipoib-mod --with-sdp-mod --with-srp-mod --with-rds-mod --with-iser-mod' --define 'build_kernel_ib 1' --define 'build_kernel_ib_devel 1' --define 'KVERSION 2.6.18-308.1.1.el5' --define 'K_SRC /lib/modules/2.6.18-308.1.1.el5/build' --define 'network_dir /etc/sysconfig/network-scripts' --define '_prefix /usr' --define '__arch_install_post %{nil}' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.src.rpm

Install mlnx-ofa_kernel RPM:

Installing mlnx-ofa_kernel RPM

cmd: rpm -ivh  --nodeps /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.unsupported.x86_64.rpm

Preparing...                ##################################################

mlnx-ofa_kernel             ##################################################

Installing kmod-mlnx-ofa_kernel RPM

Preparing...                ##################################################

kmod-mlnx-ofa_kernel        ##################################################

Install mlnx-ofa_kernel-devel RPM:

Installing mlnx-ofa_kernel-devel RPM

cmd: rpm -ivh  --nodeps /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/mlnx-ofa_kernel-devel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.unsupported.x86_64.rpm

Preparing...                ##################################################

mlnx-ofa_kernel-devel       ##################################################

Build knem RPM

Running rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define '_release 2.6.18_308.1.1.el5' --define 'KVERSION 2.6.18-308.1.1.el5' --define 'K_SRC /lib/modules/2.6.18-308.1.1.el5/build' --define '_prefix /usr' --define '__arch_install_post %{nil}' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/knem-0.9.7mlnx1-0.src.rpm

Install knem RPM:

Running rpm -iv  --nodeps /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/knem-0.9.7mlnx1-2.6.18_308.1.1.el5.x86_64.rpm

Install kernel-mft RPM:

Running rpm -iv  --nodeps /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/kernel-mft-2.7.1-2.6.18_308.1.1.el5.x86_64.rpm

Install libibverbs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-1.1.5mlnx2-1.x86_64.rpm

Install libibverbs-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-devel-1.1.5mlnx2-1.x86_64.rpm

Install libibverbs-devel-static RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-devel-static-1.1.5mlnx2-1.x86_64.rpm

Install libibverbs-utils RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-utils-1.1.5mlnx2-1.x86_64.rpm

Install libibverbs-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibverbs-debuginfo-1.1.5mlnx2-1.x86_64.rpm

Install libmthca RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmthca-1.0.6mlnx1-0.1.gbe5eef3.x86_64.rpm

Install libmthca-devel-static RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmthca-devel-static-1.0.6mlnx1-0.1.gbe5eef3.x86_64.rpm

Install libmthca-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmthca-debuginfo-1.0.6mlnx1-0.1.gbe5eef3.x86_64.rpm

Install libmverbs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmverbs-0.1.0-3.15.gd28970e.x86_64.rpm

Install libmlx4 RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmlx4-1.0.2mlnx6-1.x86_64.rpm

Install libmlx4-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmlx4-devel-1.0.2mlnx6-1.x86_64.rpm

Install libmlx4-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmlx4-debuginfo-1.0.2mlnx6-1.x86_64.rpm

Install libmverbs-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmverbs-devel-0.1.0-3.15.gd28970e.x86_64.rpm

Build libmqe RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libmqe-0.3.0-4.9.g973226d.src.rpm

Install libmqe RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmqe-0.3.0-4.9.g973226d.x86_64.rpm

Install libmqe-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libmqe-devel-0.3.0-4.9.g973226d.x86_64.rpm

Install libcxgb3 RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libcxgb3-1.3.1-1.x86_64.rpm

Install libcxgb3-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libcxgb3-devel-1.3.1-1.x86_64.rpm

Install libcxgb3-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libcxgb3-debuginfo-1.3.1-1.x86_64.rpm

Install libnes RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libnes-1.1.1mlnx1-1.x86_64.rpm

Install libnes-devel-static RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libnes-devel-static-1.1.1mlnx1-1.x86_64.rpm

Install libnes-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libnes-debuginfo-1.1.1mlnx1-1.x86_64.rpm

Install libipathverbs RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libipathverbs-1.2mlnx1-1.x86_64.rpm

Install libipathverbs-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libipathverbs-devel-1.2mlnx1-1.x86_64.rpm

Install libipathverbs-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libipathverbs-debuginfo-1.2mlnx1-1.x86_64.rpm

Build libibcm RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libibcm-1.0.5mlnx1-1.src.rpm

Install libibcm RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibcm-1.0.5mlnx1-1.x86_64.rpm

Install libibcm-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibcm-devel-1.0.5mlnx1-1.x86_64.rpm

Install libibcm-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibcm-debuginfo-1.0.5mlnx1-1.x86_64.rpm

Build libibumad RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libibumad-1.3.7.MLNX_20130110_ff06102-0.1.src.rpm

Install libibumad RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibumad-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

Install libibumad-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibumad-devel-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

Install libibumad-static RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibumad-static-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

Install libibumad-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibumad-debuginfo-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

Build libibmad RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libibmad-1.3.8.MLNX_20120424-0.1.src.rpm

Install libibmad RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibmad-1.3.8.MLNX_20120424-0.1.x86_64.rpm

Install libibmad-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibmad-devel-1.3.8.MLNX_20120424-0.1.x86_64.rpm

Install libibmad-static RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibmad-static-1.3.8.MLNX_20120424-0.1.x86_64.rpm

Install libibmad-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libibmad-debuginfo-1.3.8.MLNX_20120424-0.1.x86_64.rpm

Build ibsim RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ibsim-0.5mlnx1-0.1.g327c3d8.src.rpm

Install ibsim RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/ibsim-0.5mlnx1-0.1.g327c3d8.x86_64.rpm

Install ibsim-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/ibsim-debuginfo-0.5mlnx1-0.1.g327c3d8.x86_64.rpm

Build ibacm RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ibacm-1.0.4-1.src.rpm

Install ibacm RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/ibacm-1.0.4-1.x86_64.rpm

Install librdmacm RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/librdmacm-1.0.15-1.x86_64.rpm

Install librdmacm-utils RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/librdmacm-utils-1.0.15-1.x86_64.rpm

Install librdmacm-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/librdmacm-devel-1.0.15-1.x86_64.rpm

Install librdmacm-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/librdmacm-debuginfo-1.0.15-1.x86_64.rpm

Build libsdp RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/libsdp-1.1.108-0.16.g5cf59e8.src.rpm

Install libsdp RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libsdp-1.1.108-0.16.g5cf59e8.x86_64.rpm

Install libsdp-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libsdp-devel-1.1.108-0.16.g5cf59e8.x86_64.rpm

Install libsdp-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/libsdp-debuginfo-1.1.108-0.16.g5cf59e8.x86_64.rpm

Build compat-dapl RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_defaultdocdir /usr/share/doc/compat-dapl-1.2.19mlnx1' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/compat-dapl-1.2.19mlnx1-1.src.rpm

Install compat-dapl RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/compat-dapl-1.2.19mlnx1-1.x86_64.rpm

Install compat-dapl-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/compat-dapl-devel-1.2.19mlnx1-1.x86_64.rpm

Build dapl RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_defaultdocdir /usr/share/doc/dapl-2.0.34' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/dapl-2.0.34-1.src.rpm

Install dapl RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/dapl-2.0.34-1.x86_64.rpm

Install dapl-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/dapl-devel-2.0.34-1.x86_64.rpm

Install dapl-devel-static RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/dapl-devel-static-2.0.34-1.x86_64.rpm

Install dapl-utils RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/dapl-utils-2.0.34-1.x86_64.rpm

Install dapl-debuginfo RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/dapl-debuginfo-2.0.34-1.x86_64.rpm

Build perftest RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/perftest-2.0-0.37.g96050b8.src.rpm

Install perftest RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/perftest-2.0-0.37.g96050b8.x86_64.rpm

Install mstflint RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/mstflint-1.4mlnx4-1.21.gd948ddd.x86_64.rpm

Build sdpnetstat RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/sdpnetstat-1.60-0.3.gb6e7425.src.rpm

Install sdpnetstat RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/sdpnetstat-1.60-0.3.gb6e7425.x86_64.rpm

Build srptools RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/srptools-0.0.4mlnx3-1.src.rpm

Install srptools RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/srptools-0.0.4mlnx3-1.x86_64.rpm

Build rds-tools RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /usr' --define '_exec_prefix /usr' --define '_sysconfdir /etc' --define '_usr /usr' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/rds-tools-2.0.4mlnx1-1.src.rpm

Install rds-tools RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/rds-tools-2.0.4mlnx1-1.x86_64.rpm

Install rds-devel RPM:

Running rpm -iv  /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/RPMS/sl-release-58-4.sl/x86_64/rds-devel-2.0.4mlnx1-1.x86_64.rpm

Build ibutils RPM

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /opt/ibutils' --define '_exec_prefix /opt/ibutils' --define '_sysconfdir /etc' --define '_usr /opt/ibutils' --define '_mandir /opt/ibutils/share/man' --define 'build_ibmgtsim 1' --define '__arch_install_post %{nil}' --define 'configure_options  --with-osm=/usr ' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ibutils-1.5.7mlnx2-0.2.g05a9d1a.src.rpm

Failed to build ibutils RPM   报错build失败

See /tmp/OFED.17106.logs/ibutils.rpmbuild.log

 

5.查看报错信息

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# cat  /tmp/OFED.17106.logs/ibutils.rpmbuild.log

Running  rpmbuild --rebuild  --define '_topdir /var/tmp//OFED_topdir' --define 'dist %{nil}' --target x86_64 --define '_prefix /opt/ibutils' --define '_exec_prefix /opt/ibutils' --define '_sysconfdir /etc' --define '_usr /opt/ibutils' --define '_mandir /opt/ibutils/share/man' --define 'build_ibmgtsim 1' --define '__arch_install_post %{nil}' --define 'configure_options  --with-osm=/usr ' /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ibutils-1.5.7mlnx2-0.2.g05a9d1a.src.rpm

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

error: Failed build dependencies:

        opensm-devel is needed by ibutils-1.5.7mlnx2-0.2.g05a9d1a.x86_64

Installing /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS/ibutils-1.5.7mlnx2-0.2.g05a9d1a.src.rpm

Building target platforms: x86_64

Building for target x86_64

看到报错日志可知道:(1ibutils-1.5.7mlnx2-0.2.g05a9d1a.src.rpm软件build过程失败

                      2)提示的一些没有用户使用root执行警告信息

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

                        (3)依赖关系: opensm-devel is needed by ibutils-1.5.7mlnx2-0.2.g05a9d1a.x86_64

                      4)手工解决下面没安装的

ibutils

infiniband-diags

qperf

qperf-debuginfo

ofed-docs

openshmem

mpi-selector

openmpi_gcc

bupc

infinipath-psm

infinipath-psm-devel

mvapich2_gcc

mpitests_mvapich2_gcc

mpitests_openmpi_gcc

看到ibutils这个包安装需要依赖 opensm-devel ,值得注意的是这个包不是系统自带的,是OFED驱动中的 opensm-devel-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

 

 

 

 

 

 

6.进入OFED驱动文件的RPM源代码包,并执行编译

cd /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/src/MLNX_OFED_SRC-1.5.3-4.0.42/SRPMS

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# cd SRPMS/

[root@localhost SRPMS]# ls

bupc-2.2-370.src.rpm

compat-dapl-1.2.19mlnx1-1.src.rpm

dapl-2.0.34-1.src.rpm

ibacm-1.0.4-1.src.rpm

ib-bonding-0.9.0-43.src.rpm

ibsim-0.5mlnx1-0.1.g327c3d8.src.rpm

ibutils-1.5.7mlnx2-0.2.g05a9d1a.src.rpm

infiniband-diags-1.5.13.MLNX_20121224-0.1.src.rpm

infinipath-psm-2.9mlnx1-926.1005_open.src.rpm

kernel-mft-2.7.1-7.src.rpm

knem-0.9.7mlnx1-0.src.rpm

libcxgb3-1.3.1-1.src.rpm

libehca-1.2.2-0.1.g69e1a88.src.rpm

libibcm-1.0.5mlnx1-1.src.rpm

libibmad-1.3.8.MLNX_20120424-0.1.src.rpm

libibumad-1.3.7.MLNX_20130110_ff06102-0.1.src.rpm

libibverbs-1.1.5mlnx2-1.src.rpm

libipathverbs-1.2mlnx1-1.src.rpm

libmlx4-1.0.2mlnx6-1.src.rpm

libmqe-0.3.0-4.9.g973226d.src.rpm

libmthca-1.0.6mlnx1-0.1.gbe5eef3.src.rpm

libmverbs-0.1.0-3.15.gd28970e.src.rpm

libnes-1.1.1mlnx1-1.src.rpm

librdmacm-1.0.15-1.src.rpm

libsdp-1.1.108-0.16.g5cf59e8.src.rpm

mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.src.rpm

mpi-selector-1.0.3-1.src.rpm

mpitests-3.2-923.src.rpm

mstflint-1.4mlnx4-1.21.gd948ddd.src.rpm

mvapich-1.2.0-3635.src.rpm

mvapich2-1.9a-1.src.rpm

ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.src.rpm

ofa_kernel_dkms-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.src.rpm

ofed-docs-1.5.3-OFED.1.5.3.4.0.42.src.rpm

ofed-scripts-1.5.3-OFED.1.5.3.4.0.42.src.rpm

openmpi-1.6.4-1.src.rpm

openshmem-2.2-23217.src.rpm

perftest-2.0-0.37.g96050b8.src.rpm

qlvnictools-0.0.1-0.1.ge27eef7.src.rpm

qperf-0.4.6mlnx1-0.1.gb81434e.src.rpm

rds-tools-2.0.4mlnx1-1.src.rpm

sdpnetstat-1.60-0.3.gb6e7425.src.rpm

srptools-0.0.4mlnx3-1.src.rpm

 

 

[root@localhost SRPMS]# rpm -ivh ./*

   1:bupc                   warning: user hpcuser does not exist - using root

warning: group ecryptfs does not exist - using root   提示信息

########################################### [100%]

warning: user hpcuser does not exist - using root

warning: group ecryptfs does not exist - using root

   2:compat-dapl            warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

   3:dapl                   warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

warning: user vlad does not exist - using root99%)

warning: group ssl-cert does not exist - using root

########################################### [100%]

   4:ibacm                  warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

   5:ib-bonding             warning: user monis does not exist - using root5%)

warning: group messagebus does not exist - using root

########################################### [100%]

   6:ibsim                  warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

warning: user vlad does not exist - using root97%)

warning: group netdev does not exist - using root

########################################### [100%]

   7:ibutils                warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

   8:infiniband-diags       warning: group nogroup does not exist - using root

warning: user builder does not exist - using root)

warning: group libuuid does not exist - using root

########################################### [100%]

   9:infinipath-psm         warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  10:kernel-mft             warning: user mohammad does not exist - using root

warning: group mtl does not exist - using root

warning: user mohammad does not exist - using root

warning: group mtl does not exist - using root

########################################### [100%]

  11:knem                   warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  12:libcxgb3               warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  13:libehca                warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

  14:libibcm                warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  15:libibmad               warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  16:libibumad              warning: group nogroup does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  17:libibverbs             warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

  18:libipathverbs          warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  19:libmlx4                warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

  20:libmqe                 warning: user marcela does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group libuuid does not exist - using root

  21:libmthca               warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  22:libmverbs              warning: user vlad does not exist - using root

warning: group libuuid does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

  23:libnes                 warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  24:librdmacm              warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

  25:libsdp                 warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

  26:mlnx-ofa_kernel        warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  27:mpi-selector           warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

warning: user vlad does not exist - using root89%)

warning: group vlad does not exist - using root

########################################### [100%]

  28:mpitests               warning: user pasha does not exist - using root

warning: group messagebus does not exist - using root

########################################### [100%]

warning: user pasha does not exist - using root

warning: group messagebus does not exist - using root

  29:mstflint               warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

  30:mvapich                ########################################### [100%]

  31:mvapich2               warning: user hpcuser does not exist - using root

warning: group mtl does not exist - using root

########################################### [100%]

warning: user hpcuser does not exist - using root

warning: group mtl does not exist - using root

  32:ofa_kernel             warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  33:ofa_kernel_dkms        warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  34:ofed-docs              warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  35:ofed-scripts           warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

warning: user builder does not exist - using root)

warning: group libuuid does not exist - using root

########################################### [100%]

  36:openmpi                warning: user hpcuser does not exist - using root

warning: group mtl does not exist - using root

warning: user hpcuser does not exist - using root

warning: group mtl does not exist - using root

########################################### [100%]

  37:openshmem              warning: user hpcuser does not exist - using root

warning: group ecryptfs does not exist - using root

########################################### [100%]

warning: user hpcuser does not exist - using root

warning: group ecryptfs does not exist - using root

  38:perftest               warning: user idos does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user builder does not exist - using root

warning: group libuuid does not exist - using root

  39:qlvnictools            warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

  40:qperf                  warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

  41:rds-tools              warning: user vlad does not exist - using root

warning: group netdev does not exist - using root

warning: user vlad does not exist - using root98%)

warning: group netdev does not exist - using root

########################################### [100%]

  42:sdpnetstat             warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group vlad does not exist - using root

  43:srptools               warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

########################################### [100%]

warning: user vlad does not exist - using root

warning: group ssl-cert does not exist - using root

 

 

7.解决上面用户警告:

 

   useradd  -s /sbin/nologin -M does

   useradd  -s /sbin/nologin -M vlad

   useradd  -s /sbin/nologin -M netdev

   useradd  -s /sbin/nologin -M libuuid

   useradd  -s /sbin/nologin -M builder

   useradd  -s /sbin/nologin -M ecryptfs

   useradd  -s /sbin/nologin -M hpcuser

   useradd  -s /sbin/nologin -M mtl

   useradd  -s /sbin/nologin -M messagebus

   useradd  -s /sbin/nologin -M pasha

   useradd  -s /sbin/nologin -M mohammad

   useradd  -s /sbin/nologin -M nogroup

   useradd  -s /sbin/nologin -M ssl-cert

   useradd  -s /sbin/nologin -M idos

   useradd  -s /sbin/nologin -M  marcela

   useradd  -s /sbin/nologin -M  monis

 

 

[root@localhost SRPMS]# rpm -ivh ./*    #注意这里不是安装RPM驱动包,这个是根据源代码包,生成buitd的文件

   1:bupc                   ########################################### [100%]

   2:compat-dapl            ########################################### [100%]

   3:dapl                   ########################################### [100%]

   4:ibacm                  ########################################### [100%]

   5:ib-bonding             ########################################### [100%]

   6:ibsim                  ########################################### [100%]

   7:ibutils                ########################################### [100%]

   8:infiniband-diags       ########################################### [100%]

   9:infinipath-psm         ########################################### [100%]

  10:kernel-mft             ########################################### [100%]

  11:knem                   ########################################### [100%]

  12:libcxgb3               ########################################### [100%]

  13:libehca                ########################################### [100%]

  14:libibcm                ########################################### [100%]

  15:libibmad               ########################################### [100%]

  16:libibumad              ########################################### [100%]

  17:libibverbs             ########################################### [100%]

  18:libipathverbs          ########################################### [100%]

  19:libmlx4                ########################################### [100%]

  20:libmqe                 ########################################### [100%]

  21:libmthca               ########################################### [100%]

  22:libmverbs              ########################################### [100%]

  23:libnes                 ########################################### [100%]

  24:librdmacm              ########################################### [100%]

  25:libsdp                 ########################################### [100%]

  26:mlnx-ofa_kernel        ########################################### [100%]

  27:mpi-selector           ########################################### [100%]

  28:mpitests               ########################################### [100%]

  29:mstflint               ########################################### [100%]

  30:mvapich                ########################################### [100%]

  31:mvapich2               ########################################### [100%]

  32:ofa_kernel             ########################################### [100%]

  33:ofa_kernel_dkms        ########################################### [100%]

  34:ofed-docs              ########################################### [100%]

  35:ofed-scripts           ########################################### [100%]

  36:openmpi                ########################################### [100%]

  37:openshmem              ########################################### [100%]

  38:perftest               ########################################### [100%]

  39:qlvnictools            ########################################### [100%]

  40:qperf                  ########################################### [100%]

  41:rds-tools              ########################################### [100%]

  42:sdpnetstat             ########################################### [100%]

  43:srptools               ########################################### [100%]

用户警告解决了,继续

 

7.进入build的文件目录 cd /usr/src/redhat/SPECS/如下,buildopensm-devel.spec,发现么有。坑爹呀

[root@localhost RPMS]# cd /usr/src/redhat/SPECS/

[root@localhost SPECS]# ls

bupc.spec              libibverbs.spec       mvapich2.spec

dapl.spec              libipathverbs.spec    mvapich.spec

ibacm.spec             libmlx4.spec          ofa_kernel_dkms.spec

ib-bonding.spec        libmqe.spec           ofa_kernel.spec

ibsim.spec             libmthca.spec         ofed-docs.spec

ibutils.spec           libmverbs.spec        ofed-scripts.spec

infiniband-diags.spec  libnes.spec           openmpi-1.6.4.spec

infinipath-psm.spec    librdmacm.spec        oshmem.spec

knem.spec              libsdp.spec           perftest.spec

libcxgb3.spec          mft_kernel.spec       qlvnictools.spec

libehca.spec           mlnx-ofa_kernel.spec  qperf.spec

libibcm.spec           mpi-selector.spec     rds-tools.spec

libibmad.spec          mpitests.spec         sdpnetstat.spec

libibumad.spec         mstflint.spec         srptools.spec

8.进入/usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/

RPMS/目录,看看打包好的有么有了

 

[root@localhost RPMS]# ls

ar_mgr-1.0-0.8.gc8aa6b2.x86_64.rpm

bupc-2.2-370.x86_64.rpm

cc_mgr-1.0-0.7.g5cbb98a.x86_64.rpm

compat-dapl-1.2.19mlnx1-1.i686.rpm

compat-dapl-1.2.19mlnx1-1.x86_64.rpm

compat-dapl-devel-1.2.19mlnx1-1.i686.rpm

compat-dapl-devel-1.2.19mlnx1-1.x86_64.rpm

compat-dapl-devel-static-1.2.19mlnx1-1.i686.rpm

compat-dapl-devel-static-1.2.19mlnx1-1.x86_64.rpm

compat-dapl-utils-1.2.19mlnx1-1.i686.rpm

compat-dapl-utils-1.2.19mlnx1-1.x86_64.rpm

dapl-2.0.34-1.i686.rpm

dapl-2.0.34-1.x86_64.rpm

dapl-devel-2.0.34-1.i686.rpm

dapl-devel-2.0.34-1.x86_64.rpm

dapl-devel-static-2.0.34-1.i686.rpm

dapl-devel-static-2.0.34-1.x86_64.rpm

dapl-utils-2.0.34-1.i686.rpm

dapl-utils-2.0.34-1.x86_64.rpm

dump_pr-1.0-0.1.g79715a9.x86_64.rpm

fca-2.5.15cd296-1.x86_64.rpm

ibacm-1.0.4-1.x86_64.rpm

ibdump-1.0.6-1.x86_64.rpm

ibsim-0.5mlnx1-0.1.g327c3d8.x86_64.rpm

ibutils-1.5.7mlnx2-0.2.g05a9d1a.x86_64.rpm

ibutils2-2.1.1-0.32.g63f2b32.x86_64.rpm

infiniband-diags-1.5.13.MLNX_20121224-0.1.x86_64.rpm

infiniband-diags-guest-1.5.13.MLNX_20121224-0.1.x86_64.rpm

infinipath-psm-2.9mlnx1-926.1005_open.x86_64.rpm

infinipath-psm-devel-2.9mlnx1-926.1005_open.x86_64.rpm

kernel-mft-2.7.1-2.6.18_308.el5.x86_64.rpm

kernel-mft-2.7.1-2.6.18_308.el5xen.x86_64.rpm

kmod-mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.rhel5u8.x86_64.rpm

kmod-mlnx-ofa_kernel-xen-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.rhel5u8.x86_64.rpm

knem-0.9.7mlnx1-2.6.18_308.el5.x86_64.rpm

knem-0.9.7mlnx1-2.6.18_308.el5xen.x86_64.rpm

libcxgb3-1.3.1-1.i686.rpm

libcxgb3-1.3.1-1.x86_64.rpm

libcxgb3-devel-1.3.1-1.i686.rpm

libcxgb3-devel-1.3.1-1.x86_64.rpm

libibcm-1.0.5mlnx1-1.i686.rpm

libibcm-1.0.5mlnx1-1.x86_64.rpm

libibcm-devel-1.0.5mlnx1-1.i686.rpm

libibcm-devel-1.0.5mlnx1-1.x86_64.rpm

libibmad-1.3.8.MLNX_20120424-0.1.i686.rpm

libibmad-1.3.8.MLNX_20120424-0.1.x86_64.rpm

libibmad-devel-1.3.8.MLNX_20120424-0.1.i686.rpm

libibmad-devel-1.3.8.MLNX_20120424-0.1.x86_64.rpm

libibmad-static-1.3.8.MLNX_20120424-0.1.i686.rpm

libibmad-static-1.3.8.MLNX_20120424-0.1.x86_64.rpm

libibumad-1.3.7.MLNX_20130110_ff06102-0.1.i686.rpm

libibumad-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

libibumad-devel-1.3.7.MLNX_20130110_ff06102-0.1.i686.rpm

libibumad-devel-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

libibumad-static-1.3.7.MLNX_20130110_ff06102-0.1.i686.rpm

libibumad-static-1.3.7.MLNX_20130110_ff06102-0.1.x86_64.rpm

libibverbs-1.1.5mlnx2-1.i686.rpm

libibverbs-1.1.5mlnx2-1.x86_64.rpm

libibverbs-devel-1.1.5mlnx2-1.i686.rpm

libibverbs-devel-1.1.5mlnx2-1.x86_64.rpm

libibverbs-devel-static-1.1.5mlnx2-1.i686.rpm

libibverbs-devel-static-1.1.5mlnx2-1.x86_64.rpm

libibverbs-utils-1.1.5mlnx2-1.i686.rpm

libibverbs-utils-1.1.5mlnx2-1.x86_64.rpm

libipathverbs-1.2mlnx1-1.i686.rpm

libipathverbs-1.2mlnx1-1.x86_64.rpm

libipathverbs-devel-1.2mlnx1-1.i686.rpm

libipathverbs-devel-1.2mlnx1-1.x86_64.rpm

libmlx4-1.0.2mlnx6-1.i686.rpm

libmlx4-1.0.2mlnx6-1.x86_64.rpm

libmlx4-devel-1.0.2mlnx6-1.i686.rpm

libmlx4-devel-1.0.2mlnx6-1.x86_64.rpm

libmqe-0.3.0-4.9.g973226d.i686.rpm

libmqe-0.3.0-4.9.g973226d.x86_64.rpm

libmqe-devel-0.3.0-4.9.g973226d.i686.rpm

libmqe-devel-0.3.0-4.9.g973226d.x86_64.rpm

libmthca-1.0.6mlnx1-0.1.gbe5eef3.i686.rpm

libmthca-1.0.6mlnx1-0.1.gbe5eef3.x86_64.rpm

libmthca-devel-static-1.0.6mlnx1-0.1.gbe5eef3.i686.rpm

libmthca-devel-static-1.0.6mlnx1-0.1.gbe5eef3.x86_64.rpm

libmverbs-0.1.0-3.15.gd28970e.i686.rpm

libmverbs-0.1.0-3.15.gd28970e.x86_64.rpm

libmverbs-devel-0.1.0-3.15.gd28970e.i686.rpm

libmverbs-devel-0.1.0-3.15.gd28970e.x86_64.rpm

libnes-1.1.1mlnx1-1.i686.rpm

libnes-1.1.1mlnx1-1.x86_64.rpm

libnes-devel-static-1.1.1mlnx1-1.i686.rpm

libnes-devel-static-1.1.1mlnx1-1.x86_64.rpm

librdmacm-1.0.15-1.i686.rpm

librdmacm-1.0.15-1.x86_64.rpm

librdmacm-devel-1.0.15-1.i686.rpm

librdmacm-devel-1.0.15-1.x86_64.rpm

librdmacm-utils-1.0.15-1.i686.rpm

librdmacm-utils-1.0.15-1.x86_64.rpm

libsdp-1.1.108-0.16.g5cf59e8.i686.rpm

libsdp-1.1.108-0.16.g5cf59e8.x86_64.rpm

libsdp-devel-1.1.108-0.16.g5cf59e8.i686.rpm

libsdp-devel-1.1.108-0.16.g5cf59e8.x86_64.rpm

mft-2.7.1a-1.x86_64.rpm

mlnx-ofa_kernel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.rhel5u8.x86_64.rpm

mlnx-ofa_kernel-devel-1.5.3-OFED.1.5.3.4.0.42.g3cb72fe.rhel5u8.x86_64.rpm

mlnxofed-docs-1.5.3-4.0.42.noarch.rpm

mpi-selector-1.0.3-1.x86_64.rpm

mpitests_mvapich2_gcc-3.2-923.x86_64.rpm

mpitests_mvapich_gcc-3.2-923.x86_64.rpm

mpitests_openmpi_gcc-3.2-923.x86_64.rpm

mstflint-1.4mlnx4-1.21.gd948ddd.x86_64.rpm

mvapich2_gcc-1.9a-1.x86_64.rpm

mvapich_gcc-1.2.0-3635.x86_64.rpm

mxm-1.5.8f1b855-1.x86_64.rpm

ofed-scripts-1.5.3-OFED.1.5.3.4.0.42.x86_64.rpm

openmpi_gcc-1.6.4-1.x86_64.rpm

openshmem-2.2-23217.x86_64.rpm

opensm-3.3.13.MLNX_20130110_cd124d3-0.1.i686.rpm

opensm-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

opensm-devel-3.3.13.MLNX_20130110_cd124d3-0.1.i686.rpm

opensm-devel-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm   还好有啦

opensm-libs-3.3.13.MLNX_20130110_cd124d3-0.1.i686.rpm

opensm-libs-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm   

opensm-static-3.3.13.MLNX_20130110_cd124d3-0.1.i686.rpm

opensm-static-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

perftest-2.0-0.37.g96050b8.x86_64.rpm

qperf-0.4.6mlnx1-0.1.gb81434e.x86_64.rpm

rds-devel-2.0.4mlnx1-1.x86_64.rpm

rds-tools-2.0.4mlnx1-1.x86_64.rpm

sdpnetstat-1.60-0.3.gb6e7425.x86_64.rpm

srptools-0.0.4mlnx3-1.x86_64.rpm

 

9.手工安装脚本安装没完成的软件包

1)安装opensm-libs-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

[root@localhost RPMS]# rpm –ivh opensm-libs-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:opensm-libs            ########################################### [100%]

2)在此安装:opensm-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/opensm-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:opensm                 ########################################### [100%]

3)安装opensm-devel-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

[root@localhost RPMS]# rpm -ivh opensm-devel-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:       opensm-devel    ########################################### [100%]

4)安装opensm-static-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/RPMS/opensm-static-3.3.13.MLNX_20130110_cd124d3-0.1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:opensm-static          ########################################### [100%]

5)安装libibmad-1.3.8.MLNX_20120424-0.1.i686.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/RPMS/libibmad-1.3.8.MLNX_20120424-0.1.i686.rpm

Preparing...                ########################################### [100%]

   1:libibmad               ########################################### [100%]

6)安装libibmad-devel-1.3.8.MLNX_20120424-0.1.i686.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/libibmad-devel-1.3.8.MLNX_20120424-0.1.i686.rpm Preparing...                ########################################### [100%]

   1:libibmad-devel         ########################################### [100%]

7)安装libibmad-static-1.3.8.MLNX_20120424-0.1.i686.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/libibmad-static-1.3.8.MLNX_20120424-0.1.i686.rpm

Preparing...                ########################################### [100%]

   1:libibmad-static        ########################################### [100%]

8)安装libibumad-1.3.7.MLNX_20130110_ff06102-0.1.i686.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/libibumad-1.3.7.MLNX_20130110_ff06102-0.1.i686.rpm

Preparing...                ########################################### [100%]

   1:libibumad              ########################################### [100%]

9)安装libibumad-devel-1.3.7.MLNX_20130110_ff06102-0.1.

i686.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/libibumad-devel-1.3.7.MLNX_20130110_ff06102-0.1.

i686.rpm

Preparing...                ########################################### [100%]

   1:libibumad-devel        ########################################### [100%]

10)安装libibumad-static-1.3.7.MLNX_20130110_ff06102-0.1

.i686.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/libibumad-static-1.3.7.MLNX_20130110_ff06102-0.1

.i686.rpm

Preparing...                ########################################### [100%]

   1:libibumad-static       ########################################### [100%]

11)安装ibutils-1.5.7mlnx2-0.2.g05a9d1a.x86_64.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/ibutils-1.5.7mlnx2-0.2.g05a9d1a.x86_64.rpm

Preparing...                ########################################### [100%]

   1:ibutils                ########################################### [100%]

12)安装ibutils2-2.1.1-0.32.g63f2b32.x86_64.rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1

.5.3-4.0.42-rhel5.8-x86_64/RPMS/ibutils2-2.1.1-0.32.g63f2b32.x86_64.rpm

Preparing...                ########################################### [100%]

   1:ibutils2               ########################################### [100%]

13build infiniband-diags.spec,后生成3rpm安装文件,如下

(注意下面所有build文件生成文件路径在/usr/src/redhat/RPMS/x86_64/

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS/infiniband-diags.spec

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/redhat/RPMS/x86_64/infiniband-diags-*

Preparing...                ########################################### [100%]

   1:infiniband-diags-guest ########################################### [ 33%]

   2:infiniband-diags       ########################################### [ 67%]

   3:infiniband-diags-debugi########################################### [100%]

14bulidqperf.spec,并安装生成的rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS

/qperf.spec

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/redhat/RPMS/x86_

64/qperf-*

Preparing...                ########################################### [100%]

   1:qperf                  ########################################### [ 50%]

   2:qperf-debuginfo        ########################################### [100%]

15bulidofed-docs.spec,并安装生成的rpm

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS/ofed-docs.spec

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/redhat/RPMS/x86_

64/ofed-docs-1.5.3-OFED.1.5.3.4.0.42.x86_64.rpm

Preparing...                ########################################### [100%]

   1:ofed-docs              ########################################### [100%]

16buildoshmem.spec,并安装生成的rpm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS/oshmem.spec

error: Failed build dependencies:  报错提示:

        fca is needed by openshmem-2.2-23217.x86_64需要安装fca

        mxm is needed by openshmem-2.2-23217.x86_64需要安装mxm

17)安装刚才提示的需要安装的fcamxm

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-

1.5.3-4.0.42-rhel5.8-x86_64/RPMS/mxm-1.5.8f1b855-1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:mxm                    ########################################### [100%]

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/MLNX_OFED_LINUX-

1.5.3-4.0.42-rhel5.8-x86_64/RPMS/fca-2.5.15cd296-1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:fca                    ########################################### [100%]

INFO: updating ...

 

IMPORTANT NOTE:

===============

 

- The FCA Manager and FCA MPI Runtime library are installed in /opt/mellanox/fca directory.

- The FCA Manager will not be started automatically.

- To start FCA Manager now, type:

    /etc/init.d/fca_managerd start

 

- There should be single process of FCA Manager running per fabric.

 

- To start FCA Manager automatically after boot, type:

    /etc/init.d/fca_managerd install_service

 

- Check /opt/mellanox/fca/share/doc/fca/README.txt for quick start instructions.

18)继续build oshmem.spec,并安装

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS/oshmem.spec

 

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/redhat/RPMS/x86_64/openshmem-2.2-23217.x86_64.rpm

Preparing...                ########################################### [100%]

   1:openshmem              ########################################### [100%]

19buildmpi-selector.spec,并安装

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS/mpi-selector.spec

root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/redhat/RPMS/x86_

64/mpi-selector-1.0.3-1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:mpi-selector           ########################################### [100%]

20buildopenmpi-1.6.4.spec,并安装

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpmbuild -bb /usr/src/redhat/SPECS/openmpi-1.6.4.spec

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# rpm -ivh /usr/src/redhat/RPMS/x86_

64/openmpi-1.6.4-1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:openmpi                ########################################### [100%

20buildbupc.spec,并安装

    root@localhost x86_64]# rpmbuild -bb /usr/src/redhat/SPECS/bupc.spec

[root@localhost x86_64]# rpm -ivh /usr/src/redhat/RPMS/x86_64/bupc-2.2-370.x86_64.rpm

Preparing...                ########################################### [100%]

   1:bupc                   ########################################### [100%]

(21)bulidinfinipath-psm.spec,并安装

[root@localhost x86_64]# rpmbuild -bb /usr/src/redhat/SPECS/infinipath-psm.spec

 

[root@localhost x86_64]# rpm -ivh  /usr/src/redhat/RPMS/x86_64/infinipath-psm-*

 

Preparing...                ########################################### [100%]

   1:infinipath-psm         ########################################### [ 33%]

   2:infinipath-psm-debuginf########################################### [ 67%]

   3:infinipath-psm-devel   ########################################### [100%]

(22)下面文件直接在/usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/RPMS/目录下,安装即可

 

 [root@localhost x86_64]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/RPMS/mvapich2_gcc-1.9a-1.x86_64.rpm

Preparing...                ########################################### [100%]

   1:mvapich2_gcc           ########################################### [100%]

 

[root@localhost x86_64]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8

-x86_64/RPMS/mvapich_gcc-1.2.0-3635.x86_64.rpm

Preparing...                ########################################### [100%]

   1:mvapich_gcc            ########################################### [100%]

 

[root@localhost x86_64]# rpm -ivh /usr/src/MLNX_OFED_LINUX-1.5.3-4.0.42-rhel5.8-x86_64/RPMS/mpitests_*

Preparing...                ########################################### [100%]

   1:mpitests_openmpi_gcc   ########################################### [ 33%]

   2:mpitests_mvapich2_gcc  ########################################### [ 67%]

   3:mpitests_mvapich_gcc   ########################################### [100%]

10. 设置开机启动,与Linux常用服务设置一样

1)手工启动,查看服务是否正常

[root@localhost x86_64]# /etc/init.d/openibd restart 

Unloading HCA driver:                                      [  OK  ]

Loading HCA driver and Access Layer:                       [  OK  ]

Setting up InfiniBand network interfaces:

Bringing up interface ib0:                                 [  OK  ]

Bringing up interface ib1:                                 [  OK  ]

Setting up service network . . .                           [  done  ]

2)设置开机启动

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# chkconfig --level 5 openibd on   设置开启启动服务

 

11.配置IB卡文件ifcfg-ib0,同网卡配置一样,

 

12设置开机启动opensm服务,与Linux常用服务设置一样

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# chkconfig --level 5 opensm on

13.查看IB卡,同时可以Ping测试。

[root@localhost MLNX_OFED_SRC-1.5.3-4.0.42]# hca_self_test.ofed      

---- Performing Adapter Device Self Test ----

Number of CAs Detected ................. 1

PCI Device Check ....................... PASS

Kernel Arch ............................ x86_64

Host Driver Version .................... OFED-internal-1.5.3-4.0.42: 2.6.18-308.1.1.el5

Host Driver RPM Check .................. PASS

Firmware on CA #0 VPI .................. v2.11.550

Firmware Check on CA #0 (VPI) .......... NA

    REASON: NO required fw version

Host Driver Initialization ............. PASS

Number of CA Ports Active .............. 1

 

© 著作权归作者所有

B
粉丝 2
博文 5
码字总数 18059
作品 0
昌平
项目经理
私信 提问
Linux 安装OFED(InfiniBand驱动)

@BaoLinChuan 你好,想跟你请教个问题:您好,看到您的博文了,因为我也在安装InfiniBand驱动,但是解决安装包的问题之后,在选择安装所以文件之后,出现如下问题: make[1]: Entering dire...

nicole587
2014/10/15
2.6K
0
英伟达收购Mellanox,包含哪些技术和产品?

版权声明:更多内容,请关注【架构师技术联盟】公众号 https://blog.csdn.net/BtB5e6Nsu1g511Eg5XEg/article/details/88415020 3月11日消息,英伟达官方宣布已经达成协议,以69亿美元现金收购...

架构师技术联盟
03/12
0
0
Vmware Workstation + Suse Linux 11 SP3 + db2 purescale V10.5 (二)

本文详细记录了DB2 purescale 10.5在VMware Workstation 上的安装过程,如果大家看了本人的博文后,实践过程中有什么问题,欢迎加本人微信84077708,我将尽我所能为大家解惑。 两台虚拟机的主...

jianght_2014
2017/06/13
0
0
红帽企业 Linux 5.8 正式版发布

红帽企业 Linux 5.8 正式版发布了,红帽 5.8 支持新的硬件平台,以及以下改进内容: 支持电源管理 QoS,提供设备级别的自动电源管理策略,在关键的产品中,系统管理员可启用高性能低延迟的模...

红薯
2012/02/22
8.9K
5
关于InfiniBand几个基本知识点解释

IP网络协议如TCP/IP,具有转发丢失数据包的特性,网络不良时要不断地确认与重发,基于这些协议的通信也会因此变慢,极大地影响了性能。与之相比,IB使用基于信任的、流控制的机制来确保连接的...

架构师技术联盟
2018/11/01
0
0

没有更多内容

加载失败,请刷新页面

加载更多

Handler简解

Handler 这里简化一下代码 以便理解 Handler不一定要在主线程建 但如Handler handler = new Handler(); 会使用当前的Looper的, 由于要更新UI 所以最好在主线程 new Handler() { mLooper = Lo...

shzwork
19分钟前
2
0
h5获取摄像头拍照功能

完整代码展示: <!DOCTYPE html> <head> <title>HTML5 GetUserMedia Demo</title> <meta charset="utf-8"> <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum......

诗书易经
22分钟前
2
0
正向代理和反向代理

文章来源 运维公会:正向代理和反向代理 1、正向代理 (1)服务对象不同 正向代理服务器的服务对象是客户端,可以将客户端和代理服务器看作一个整体。 (2)配置方法不同 需要在客户端配置代...

运维团
38分钟前
3
0
5个避免意外论文重复率高的方法

即使你不是故意抄袭,但你可能在无意中抄袭了别人的论文, 这个叫做意外抄袭,它可能正发生在你身上,如果你不熟悉学术 道德规范,这里将告诉你5个基本的方法来避免意外抄袭。 Tip1 熟悉其他...

论文辅导员
39分钟前
3
0
Maven通过profiles标签读取不同的配置

<profiles> <profile> <id>dev</id> <properties> <profiles.active>dev</profiles.active> </properties> ......

时刻在奔跑
45分钟前
1
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部