com.android.tools.build:gradle:X.XX.XX:gradle.jar
博客专区 > artshell 的博客 > 博客详情
com.android.tools.build:gradle:X.XX.XX:gradle.jar
artshell 发表于4年前
com.android.tools.build:gradle:X.XX.XX:gradle.jar
  • 发表于 4年前
  • 阅读 17367
  • 收藏 7
  • 点赞 2
  • 评论 5

【腾讯云】买域名送云解析+SSL证书+建站!>>>   

摘要: Could not download artifact 'com.android.tools.build:gradle:0.13.0:gradle.jar'插件无法下载问题

在使用Android Studio 这个IDE时,出现com.android.tools.build:gradle:X.XX.XX:gradle.jar 插件无法下载问题

可能的原因就是网速不好或者依赖仓库的下载网址被墙了,可以配置代理试试。比如,android studio 定义的默人依赖仓库为jcenter()仓库.如下

打开项目下的 build.gradle文件,不是Module下

allprojects {
    repositories {
        jcenter()
    }
}

网上搜索到一些方法如下:

第一种:

需要在android studio 中配置gradle的代理,当然是用goagent了。

打开setting->gradle->Gradle VM Options

-Dhttp.proxyHost=127.0.0.1 -Dhttp.proxyPort=8087

设置生成功后,重启android studio ,速度会非常快。

第二种:

官网方法,在出现无法下载时,系统会自动提示!官网说明戳这里

同样使用goagent代理

A:配置HTTP代理

打开项目下的gradle.properties文件

systemProp.http.proxyHost=127.0.0.1
systemProp.http.proxyPort=8087
systemProp.http.nonProxyHosts=localhost
B:配置 HTTPS代理
systemProp.https.proxyHost=127.0.0.1
systemProp.https.proxyPort=8087
systemProp.https.nonProxyHosts=localhost


  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 2
博文 56
码字总数 5163
评论 (5)
小萝莉菜鸟
还是不行呢?但是我用浏览器可以把这个东西下载下来,放到D:\androidstudio\gradle\gradle-2.2.1\lib这里面也没有用
artshell

引用来自“小萝莉菜鸟”的评论

还是不行呢?但是我用浏览器可以把这个东西下载下来,放到D:\androidstudio\gradle\gradle-2.2.1\lib这里面也没有用
你用的Android Stuido 版本是多少? 建议用 Android Studio 1.2 正式版,正式版已经将gradle打包好了,你不用再下载了!
用纸狂魔
你好,我用的是 1.2.2版本的~
遇到的问题是:Error:Could not download artifact 'gradle.jar (com.android.tools.build:gradle:1.2.2)': No cached version available for offline mode
试用了你的方法还是不行~~求指导
用纸狂魔
打开另一个项目报这样的错:Error:Could not GET 'https://repo1.maven.org/maven2/com/android/tools/build/gradle/1.0.1/gradle-1.0.1.pom'.
<a href="toggle.offline.mode">Enable Gradle 'offline mode' and sync project</a>
artshell

引用来自“悠悠蛋炒饭”的评论

你好,我用的是 1.2.2版本的~
遇到的问题是:Error:Could not download artifact 'gradle.jar (com.android.tools.build:gradle:1.2.2)': No cached version available for offline mode
试用了你的方法还是不行~~求指导
不是我的方法有问题,而是你启用了离线模块,都提示你了,“离线模块下没有此版本”
×
artshell
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: