升级zabbix从1.8到2.2
升级zabbix从1.8到2.2
AnthonyYau 发表于3年前
升级zabbix从1.8到2.2
  • 发表于 3年前
  • 阅读 592
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 技术升级10大核心产品年终让利>>>   

2.2新版本主要提供新功能:
1、VMware hypervisors and virtual machines监控;
2、可加载的数据收集模块;
3、支持使用正则表达式从日志、文本文件和web页面提取文本;

从1.8升级到2.2,需要先升级到2.1,可以只升级zabbix_server和web前端,zabbix_agent可以不用升级,如果使用了zabbix_proxy也需要升级。

从1.8升级到2.0,需要修改很多数据表结构,特别是那些大表(history、history_uint、history_str、trends_uint、trends),如果已经有很多数据,并数据库使用的是mysql 5.1或5.5时,因其不支持online DDL,在执行ALTER TABLE时需要重建表,将非常慢,最好先将数据库升级到mysql 5.6或衍生版percona 5.6或mariadb 10。

zabbix升级步骤(zabbix proxy升级也一样的步骤):
1、停止zabbix_server,避免有数据写入;
2、备份数据库数据;
3、升级数据库表结构,执行upgrades/dbpatches/2.0/mysql/patch.sql脚本,2.2在启动zabbix_server或proxy时会自动升级表结构;
4、备份旧版php文件、zabbix二进制文件、zabbix配置文件和启动脚本;
5、安装新版zabbix server;
6、检查配置文件,去除新版本不兼容的参数;
7、启动新版zabbix server,升级2.2版本时,通过查看日志,当数据库升级完成后并成功后,再继续下步操作;
8、安装新版zabbix web端;





共有 人打赏支持
粉丝 30
博文 85
码字总数 93611
×
AnthonyYau
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: