小程序插件使用- 抽奖助手

原创
2018/07/26 15:36
阅读数 6.5K

在使用抽奖助手插件前都得先去小程序开放平台添加插件到自己的小程序

设置 --- 第三方服务 --- 插件管理 ---添加插件 --- 抽奖助手

抽奖助手插件的AppID: wx01bb1ef166cd3f4e

抽奖助手插件的版本号:0.1.0 具体怎样使用抽奖助手插件呢?

接入步骤如下:

1.在app.json文件加入插件引入配置

 "plugins": {
   "lottery": {
     "version": "0.1.0",
     "provider": "wx01bb1ef166cd3f4e"
   }
}

2.新建一个Page: lottery;会自动生成四个文件 lottery.js,lottery.json,lottery.wxml,lottery.wxss

3.我们在lottery.json文件里面加入如下配置:

 "usingComponents": {
     "lotterycard": "plugin://lottery/card"
   }

4.在lottery.wxml 中引入组件,代码如下:

<lotterycard lottery='7EQUKGM0XRe' redirect='page'>
</lotterycard>

注意:

  • 1.lottery 这个值是动态配置的,需要先在“抽奖助手”小程序创建好抽奖后获得
  • 2.redirect 点击奖品图片跳转方式。 none: 不跳转; page: 跳转到插件抽奖详情页面 (基础库版本 >= 2.1.0); mina:跳转到抽奖助手小程序抽奖详情页(这个属于的设置前提是需要先绑定小程序 抽奖助手)

5.运行~

error示例:thirdScriptError sdk uncaught third Error Page is not a function TypeError: Page is not a function

thirdScriptError sdk uncaught third Error Page is not a function TypeError: Page is not a function at http://127.0.0.1:31034/appservice/**onlineplugin**/wx01bb1ef166cd3f4e/0.1.0/appservice.js:1697:574

解决:基础库版本太低了,如官方文档设置>=2.1.0

基础库版本: 目前插件支持的基础库版本为 >= 2.1.0, 使用前,请在公众平台小程序后台"设置-基本设置-基础库最低版本设置",将最低版本要求设置为 2.1.0

更多使用文档可以参考抽奖助手插件官方文档: https://mp.weixin.qq.com/wxopen/plugindevdoc?appid=wx01bb1ef166cd3f4e

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部