文档章节

mysqlnd cannot connect to MySQL 4.1+ using the...

RablePHP
 RablePHP
发布于 2014/11/12 12:58
字数 115
阅读 83
收藏 0

mysql数据库提示错误!

mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file


用这一个很好的方法,把密码改过。就OK了

SET PASSWORD FOR username@"%" = PASSWORD('123456');

© 著作权归作者所有

RablePHP
粉丝 15
博文 47
码字总数 11895
作品 0
巴南
程序员
私信 提问
mysqlnd cannot connect to MySQL 4.1+ using the ...

今天用php5.4时遇上了“mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication”的问题,解决办法是把my.cn中的 old_passwords = 1 改为 old_passwords = 0看下使用数......

Risol
2012/11/11
594
0
php使用mysqlnd引发的一些问题处理

现在CentOS 5.11使用的仍是比较老旧的mysql 5.0.59 服务器版本,PHP也是使用的最高的也是5.3.3(使用yum -y install php53安装)。从官方看5.3的最后一个版本为5.3.29已经于2014年8月份停止支持...

mickelfeng
2015/10/15
40
0
mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication解决办法

Fatal error: Uncaught exception ‘PDOException’ with message ‘SQLSTATE[HY000] [2000] mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an ......

底火
2015/03/20
0
0
一个函数引发的MySQL驱动问题

前两天在一个php脚本中使用mysqlifetchall()来获取全部结果集,但却提示该方法undefined,只好退回,使用mysqlfetchrow()这个方法,一行一行的获取记录,效率很慢。后来查询得到: 1, mysqli...

vinci321
2018/03/08
28
0
PHP 5.3.0以上推荐使用mysqlnd驱动

1.什么是mysqlnd驱动? PHP手册上的描述: MySQL Native Driver is a replacement for the MySQL Client Library (libmysql). MySQL Native Driver is part of the official PHP sources as of......

月影又无痕
2013/06/27
473
1

没有更多内容

加载失败,请刷新页面

加载更多

安全组和云防火墙的区别

前言 熟悉云平台的朋友可能都会注意到这样一个事情:无论公有云还是私有云,创建虚拟机的时候都需要选择安全组,来对虚拟机进行安全防护;有的云平台在VPC里,还能选择防火墙,ZStack在3.6版...

ZStack社区版
15分钟前
1
0
教育性app开发的重要性和好处

在这个精通技术的世界中,流行的app主导着无聊的教育系统。当我们将技术和教育结合在一起时,它将带来当代以及强大的学习资源。因此,将教育移动app集成到您的学习过程中,并根据自己的信念把...

a429011717
16分钟前
1
0
IE6/7/8如何兼容CSS3属性

本文转载于:专业的前端网站➩IE6/7/8如何兼容CSS3属性 最近在工作中总是要求IE8兼容CSS3属性,在网上搜了搜主要是引入了一个htc文件(ie-css3.htc或者PIE.htc。个人认为这两个文件的作用差不...

前端老手
31分钟前
2
0
手把手教你ALLEGRO的约束规则的设置教程!

约束规则的设置 分三步, 定义规则(一、基本约束规则设置:1、线间距设置;2、线宽设置;3、设置过孔;4、区域约束规则设置;5、设置阻抗;6、设置走线的长度范围;7、设置等长:7.1、不过电阻的NET 等...

demyar
33分钟前
3
0
完美解决H5滚动滑动穿透方案:不使用系统滚动

网上有很多黑科技解决这个问题,都不是从根本去解决,例如通过js控制弹出时html加上position:fixed; 弹窗关闭后再去掉该样式,总觉得不太对,像是打补丁。 今天终于找到了滚动穿透的原因和完...

未来cc
38分钟前
5
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部