文档章节

dubbo-admin 环境搭建注意点

GoogleFan
 GoogleFan
发布于 2015/07/23 16:32
字数 232
阅读 11394
收藏 14
  • github 源码: https://github.com/alibaba/dubbo.git

  • 下载到Eclipse 后,重新用Maven工程载入。

  • 修改pom文件:

1、webx的依赖改为3.1.6版;

    <dependency>
        <groupId>com.alibaba.citrus</groupId>
        <artifactId>citrus-webx-all</artifactId>
        <version>3.1.6</version>
    </dependency>

2、添加velocity的依赖,我用了1.7;

    <dependency>
        <groupId>org.apache.velocity</groupId>
        <artifactId>velocity</artifactId>
        <version>1.7</version>
    </dependency>

3、对依赖项dubbo添加exclusion,避免引入旧spring

    <dependency>
        <groupId>com.alibaba</groupId>
        <artifactId>dubbo</artifactId>
        <version>${project.parent.version}</version>
        <exclusions>
            <exclusion>
                <groupId>org.springframework</groupId>
                <artifactId>spring</artifactId>
            </exclusion>
        </exclusions>
    </dependency>

4、webx已有spring 3以上的依赖,因此注释掉dubbo-admin里面的spring依赖

    <!--<dependency>-->
        <!--<groupId>org.springframework</groupId>-->
        <!--<artifactId>spring</artifactId>-->
    <!--</dependency>-->

确定war包解压后lib目录没有spring 3 以下的依赖就行。

  • 下载zookeeper :http://apache.fayea.com/zookeeper/stable/zookeeper-3.4.6.tar.gz

    修改 conf下的zoo_sample.cfg 为zoon.cfg并修改里面的数据存储位置。

  • 用tomcat发布dubbo-admin 并修改 WEB-INF下的dubbo.properties 

    dubbo.registry.address=zookeeper://127.0.0.1:2181 地址和端口修改为对应的zookeeper

    访问dubbo-admin:


© 著作权归作者所有

共有 人打赏支持
GoogleFan
粉丝 10
博文 33
码字总数 6749
作品 0
朝阳
后端工程师
私信 提问
加载中

评论(7)

沈浩z
好像包很多下不了
h
hanyang
192.168.112.8和192.168.112.9分别运行zookeeper server 我在192.168.112.8上
./zkCli.sh -server localhost 2181,然后再本地机器上运行dubbo admin依然
tomcat中卡在INFO zkclient.ZkEventThread - Starting ZkClient event thread.
h
hanyang

引用来自“hanyang”的评论

tomcat中卡在INFO zkclient.ZkEventThread - Starting ZkClient event thread.

引用来自“GoogleFan”的评论

先开启 zkClient
好的,我试试,谢谢~
GoogleFan
GoogleFan

引用来自“hanyang”的评论

tomcat中卡在INFO zkclient.ZkEventThread - Starting ZkClient event thread.
先开启 zkClient
h
hanyang
tomcat中卡在INFO zkclient.ZkEventThread - Starting ZkClient event thread.
GoogleFan
GoogleFan

引用来自“shuimuzhushui”的评论

为什么我按照你说的处理,仍然是那个错误呢,求指导。
什么错误?
s
shuimuzhushui
为什么我按照你说的处理,仍然是那个错误呢,求指导。
dubbo框架Demo之dubbo-admin管理平台和zookeeper注册中心搭建

dubbo框架Demo之dubbo-admin管理平台和zookeeper注册中心搭建 一、安装环境 系统软件环境 单机 系统Centos7.3 java: jdk1.8.0_181 maven: apache-maven-3.5.4 tomcat: apache-tomcat-8.5.30...

bestlope
2018/09/07
0
0
基于dubbo快速发布restful服务

本文使用官方项目示例,基于dubbox发布restful服务。jdk,eclipse、maven神马环境的就不讲了,自行baidu之。 dubbox下载、编译 下载地址:https://github.com/dangdangdotcom/dubbox 下载方式...

不简单666
2017/05/21
0
0
spring boot + dubbo + zookeeper 搭建及问题解决

Dubbo 是一款高性能Java RPC框架,现在有很多公司都在使用,鉴于技多不压身的原则,折腾一下这玩意 简介 spring boot 是当前比较流行的开发工具组合框架,他并不是一个新框架;由于它集合了很多...

zerokb-小浪
2018/09/30
0
0
JEESZ分布式框架开发环境部署

摘要: 环境搭建: 1.环境准备 1.开发工具: Eclipse IDE(建议使用高一点的版本) 2.JDK版本:JDK1.7 3.项目管理: Maven3.1.1 2.安装步骤 1.安装jdk1.7并配置环境变量(相信大家都会做,这里...

qq593e3b758e013
2017/09/06
0
0
Linux Zookeeper Dubbo弄弄环境

背景和什么什么就不说了,记录记录问题和过程来着。 1. 环境: 2.安装: 解压缩tar.gz包,使用命令: JDK的bin文件安装,可参考:http://my.oschina.net/u/1991646/blog/703205 3.配置和启动...

郁极风
2016/06/30
58
0

没有更多内容

加载失败,请刷新页面

加载更多

OSChina 周一乱弹 —— 加油,还有11个小时就下班了

Osc乱弹歌单(2019)请戳(这里) 【今日歌曲】 @_全村的希望 :吴亦凡把大碗面正儿八经做成单曲了,你别说,还挺好听 《大碗宽面》- 吴亦凡 手机党少年们想听歌,请使劲儿戳(这里) @tom_t...

小小编辑
28分钟前
74
8
C++ vector和list的区别

1.vector数据结构 vector和数组类似,拥有一段连续的内存空间,并且起始地址不变。 因此能高效的进行随机存取,时间复杂度为o(1); 但因为内存空间是连续的,所以在进行插入和删除操作时,会造...

shzwork
今天
6
0
Spring之invokeBeanFactoryPostProcessors详解

Spring的refresh的invokeBeanFactoryPostProcessors,就是调用所有注册的、原始的BeanFactoryPostProcessor。 相关源码 public static void invokeBeanFactoryPostProcessors(Configu......

cregu
昨天
5
0
ibmcom/db2express-c_docker官方使用文档

(DEPRECIATED) Please check DB2 Developer-C Edition for the replacement. What is IBM DB2 Express-C ? ``IBM DB2 Express-C``` is the no-charge community edition of DB2 server, a si......

BG2KNT
昨天
4
0
Ubuntu 18.04.2 LTS nvidia-docker2 : 依赖: docker-ce (= 5:18.09.0~3-0~ubuntu-bionic)

平台:Ubuntu 18.04.2 LTS nvidia-docker2 版本:2.0.3 错误描述:在安装nvidia-docker2的时候报dpkg依赖错误 nvidia-docker2 : 依赖: docker-ce (= 5:18.09.0~3-0~ubuntu-bionic) 先看一下依......

Pulsar-V
昨天
4
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部