文档章节

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead.报错!

我爱睡觉
 我爱睡觉
发布于 2017/06/24 17:39
字数 48
阅读 4
收藏 0
1.项目右键 ->android tools->Fix Project
2.如果不可以,检查Project->Properties->Java Compiler
确认JDK compliance被设置为1.6,并且enable specific seetings.

本文转载自:http://blog.csdn.net/zhangmiaoping23/article/details/41748435

我爱睡觉
粉丝 3
博文 2120
码字总数 0
作品 0
南昌
私信 提问
Android可以使用jdk1.7吗

我下载了zxing的源码和实例,但是demo中用了大量jdk1.7才支持的函数,比如switch(String)等,导致我编译不过去,把编译环境改为jdk1.7之后,android又报错:Android requires compiler compl...

qhboy
2014/03/03
5.3K
6
adt-bundle-windows-x86 出现的问题

我一直不喜欢android ,因为它的工具环境太恶心了。启动模拟机占资源太大,公司发的破电脑能被跑死。 人在江湖呀,不说那些了,说说关于如题出现的问题。 我下载的是 adt-bundle-windows-x86...

庸夫俗子
2013/01/18
2.8K
1
Android requires compiler compliance level 5.0 ...

重装操作系统后,要重新配置Android开发环境。配置成功后,添加原本项目时却出现了错误! Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Andro......

垂盆草
2012/03/05
218
0
Android requires compiler compliance level 5.0 ...

重装操作系统后,要重新配置Android开发环境。配置成功后,添加原本项目时却出现了错误! Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Andro......

gavin_jin
2012/04/14
459
0
更新到 JDK 7 后, Eclipse ADT 报错了

刚刚装了个 JDK 7 ,然后启动 Eclipse ,设置了默认编译级别是 1.7 ,后发现有如下的报错信息 [2011-08-01 10:31:45 - AndOschina] Android requires compiler compliance level 5.0. Pleas...

红薯
2011/08/01
6K
11

没有更多内容

加载失败,请刷新页面

加载更多

Netty整合Protobuffer

现在我们都知道,rpc的三要素:IO模型,线程模型,然后就是数据交互模型,即我们说的序列化和反序列化,现在我们来看一下压缩比率最大的二进制序列化方式——Protobuffer,而且该方式是可以跨...

算法之名
24分钟前
14
0
如何用C++实现栈

栈的定义 栈(stack)又名堆栈,它是一种运算受限的线性表。限定仅在表尾进行插入和删除操作的线性表。这一端被称为栈顶,相对地,把另一端称为栈底。向一个栈插入新元素又称作进栈、入栈或压...

BWH_Steven
43分钟前
4
0
编程作业20190210900169

1编写一个程序,提示用户输入名和姓,然后以“名,姓”的格式打印出来。 #include <stdio.h>#include <stdlib.h> int main(){ char firstName[20]; char lastName[20]; print......

1李嘉焘1
55分钟前
12
0
补码的优点及原理分析

只讨论整数 1.计算机内部为什么没有减法器? 减法运算本身其实就是加法,如x - y即x +(-y),所以只需要将负数成功表示出来并可以参加加法运算,那加法器就可同时实现“+”和“-”的运算。这...

清自以敬
今天
76
0
Docker 可视化管理 portainer

官网安装指南: https://portainer.readthedocs.io/en/latest/deployment.html docker-compose.yml 位置,下载地址:https://downloads.portainer.io/docker-compose.yml...

Moks角木
今天
9
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部