【vuex】【vue】【兼容】IE报vuex requires a Promise polyfill in this browser问题解决

原创
2017/10/26 00:02
阅读数 1.8K

IE报vuex requires a Promise polyfill in this browser问题解决

使用Vuex, IE浏览器报错

使用Vuex, IE浏览器报错

因为使用了 ES6 中用来传递异步消息的的Promise,而IE低版本的浏览器不支持。

浏览器兼容图

解决方案

第一步

安装 babel-polyfill 。 babel-polyfill可以模拟ES6使用的环境,可以使用ES6的所有新方法

npm install --save babel-polyfill

第二步

在 Webpack/Browserify/Node中使用

在webpack.config.js文件中,使用

module.exports = {
  entry: {
    app: ["babel-polyfill", "./src/main.js"]
  }
};

替换

module.exports = {
  entry: {
    app:  './src/main.js'
  }
}
展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部