加载web项目时报的错误:Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modul
加载web项目时报的错误:Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modul
燃烧NO1 发表于1年前
加载web项目时报的错误:Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modul
  • 发表于 1年前
  • 阅读 3
  • 收藏 0
  • 点赞 0
  • 评论 0

新睿云服务器60天免费使用,快来体验!>>>   

用eclipse开发的servlet项目不能加载到tomcat6.0服务器,原因是:servlet的版本高了

<installed facet="jst.web" version="3.0"/> 只要将version="3.0"改成version="2.5",然后重启eclipse即可!!!

具体操作步骤:

找到你的eclipse:D:\eclipse\workspace-jee\项目名称\.settings\org.eclipse.wst.common.project.facet.core.xml这个配置文件,将<installed facet="jst.web" version="3.0"/> 只要将version="3.0"改成version="2.5",然后重启eclipse即可!!!

或者下载高版本的Tomcat (Tomcat  7.0以上)。

 

但是有的时候按照上述方法直接修改之后的话, 会报告找不到org.eclipse.wst.common.project.facet.core.xml该文件错误, 所以最稳妥的方法就是在创建该Dynamic web project的时候就选择低于3.0的版本. 

  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 23
博文 87
码字总数 67020
×
燃烧NO1
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: