mahout 0.9的编译
mahout 0.9的编译
1987times 发表于3年前
mahout 0.9的编译
  • 发表于 3年前
  • 阅读 37
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 学生专属云服务套餐 10元起购>>>   

mahout的bin版本目前只支持hadoop 1.2.1。但是客户使用hadoop2版本,需要自己手动编译一下

mahout的编译脚本如下:

#!/bin/bash
mvn clean package -Dhadoop.profile=200 -Dhadoop.2.version=2.2.0 -DskipT

还一个地方需要改动

mahout工程中的integration需要修改pom.xml的依赖

hbase-client 原来是0.95.2-hadoop1 改成0.95.2-hadoop2 这样就编译成功了

共有 人打赏支持
粉丝 4
博文 57
码字总数 17894
×
1987times
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: