Lombok插件有望被Intellij IDEA收编以改善兼容性问题

原创
08/27 14:19
阅读数 68

1. 前言

最近两个版本的Intellij IDEA没有办法使用lombok插件了,这种问题已经出现了多次,导致胖哥依然使用2020.1的旧版本。其实很多人和我一样也回滚到了旧版本。我一直认为是lombok插件作者没有及时跟进的问题,事实上我错怪作者了。

2. lombok失效的原因

当我尝试向lombok作者寻求答案时被告知“it's jetbrain's fault and not my fault.”,他表示他也很冤枉,他早在两周前就已经同IDEA官方进行了沟通并寻求问题的解决方案。

Intellij IDEA工程师Peter Gromov最初把这个问题又抛给了原作者:

这个问题是你的Lombok插件代码中的某些类存在一些不可用的成员,但是这些成员被缓存起来了,即使你插件已经检测出这些缓存失效了,但是却并没有真正的让它们失效。

但是作者不乐意了:这明明是IDEA插件平台处理机制的问题,怎么是我的锅呢?😓

然后两个大佬针锋相对,一番摆事实讲道理后Intellij IDEA官方意识到是自己的问题。过程十分的精彩。

激烈的学术交流

IntelliJ IDEA 官方表示会在2020.2.1修复这个问题,同时对Lombok作者表达了歉意。

3. 这个问题目前已经修复

IDEA 2020.2.1正式版已经发布,那么这个问题也解决了,但是目前插件市场还没有实装。🚫不要通过商店安装。

你可以到lombok的插件市场页在线安装,地址:https://plugins.jetbrains.com/plugin/download?rel=true&updateId=87712

保持IDEA打开,然后按下图操作

也可以关注公众号:码农小胖哥 回复关键字lombokeap直接获取离线安装包,离线安装。

4. 额外的消息

Lombok出问题这么长时间以来,造成了重大的影响,很多人因此都没有对IDEA升级。官方已经意识到了Lombok的影响力,已经准备着手启动官方支持lombok的计划,目前还在和插件作者沟通。

关注公众号:Felordcn获取更多资讯

个人博客:https://felord.cn

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部